php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44634 REMOTE_ADDR returns the same ip as SERVER_ADDR
Submitted: 2008-04-04 06:26 UTC Modified: 2008-04-04 09:03 UTC
From: net dot gatekeeper at gmail dot com Assigned:
Status: Not a bug Package: *Web Server problem
PHP Version: 5.2CVS-2008-04-04 (snap) OS: Linux
Private report: No CVE-ID: None
 [2008-04-04 06:26 UTC] net dot gatekeeper at gmail dot com
Description:
------------
I have revised PhpFreeChat in my host, and it was working fine there. Then, my contact installed it in his server and this problem showed up.

$_SERVER['REMOTE_ADDR'] returns the same value as his host address, $_SERVER['SERVER_ADDR'].

I think this has something to do with some misconfiguration in either Apache or Php, I just wasn't sure what it is.

Is there anything I can do to fix this problem? or is there a way how I can get the client's IP in any way possible?

Here is a phpinfo() in his host --> http://doujin-moe.com/chat2/servertest.php

Here is a phpinfo() in my host --> http://www.gpdesignsph.com/dah/servertest.php


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-04-04 09:03 UTC] scottmac@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

The server is sitting behind a proxy of some kind, this has nothing to do with PHP since it gets those values from the SAPI, in this case Apache 2.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 20 21:03:37 2021 UTC