php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44631 missing USER Login in apache logs
Submitted: 2008-04-03 18:18 UTC Modified: 2008-04-03 21:03 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: eslusarev at nvidia dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5.2.5 OS: Linux
Private report: No CVE-ID:
 [2008-04-03 18:18 UTC] eslusarev at nvidia dot com
Description:
------------
Apache missing REMOTE_USER login when it writes logs, but only after PHP scripts
I tryed to build system with PHP 5.2.5, 5.2.4, 4.4.8 and on all versions of Apache starting from 2.0 to 2.2 and using authorization by many modules mod_auth_kerb, mod_auth_ldap, mod_ntlm, mod_auth_ntlm_winbind and many others... At all times I have this trouble... auth completed ok, in $_SERVER I have REMOTE_USER with correct name, but in logs missing this user name and I have only "-" there... on other modules like mod_perl and other I have no this error --> error with PHP :-/ and I have tryed to setup PHP on Apache 1.3 and at this time I have no this error, but there are I can't to setup some needed modules :-/


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-04-03 21:03 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 09:02:29 2014 UTC