php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #44518 Add way to fetch all notices instead of just one with pg_last_notice()
Submitted: 2008-03-24 17:59 UTC Modified: 2015-12-17 00:54 UTC
Votes:9
Avg. Score:4.2 ± 0.9
Reproduced:7 of 7 (100.0%)
Same Version:6 (85.7%)
Same OS:6 (85.7%)
From: smagen at yandex dot ru Assigned: yohgaki (profile)
Status: Closed Package: PostgreSQL related
PHP Version: * OS: *
Private report: No CVE-ID: None
 [2008-03-24 17:59 UTC] smagen at yandex dot ru
Description:
------------
The function pg_last_notice returns only last notice for the query. But in the PostgreSQL query may produce several notices. It is wanted to have possibility to get all the notices for the query.

Expected result:
----------------
Possibility to get all the notices for the query

Actual result:
--------------
Only last notice may be received.
(May be program can find other notices in logs, but I think this method is not true)

Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-01-01 23:14 UTC] jani@php.net
-Summary: Notices in PostgreSQL +Summary: Add way to fetch all notices instead of just one with pg_last_notice() -Package: Feature/Change Request +Package: PostgreSQL related -Operating System: any +Operating System: * -PHP Version: 5.2.5 +PHP Version: *
 [2012-03-31 05:37 UTC] yohgaki@php.net
-Assigned To: +Assigned To: yohgaki
 [2015-12-17 00:54 UTC] yohgaki@php.net
-Status: Assigned +Status: Closed
 [2015-12-17 00:54 UTC] yohgaki@php.net
Duplicate of bug #31021

Implemented.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Feb 07 06:05:51 2023 UTC