php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44515 PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/2
Submitted: 2008-03-24 05:09 UTC Modified: 2008-03-25 13:15 UTC
From: 24498936 at qq dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5.2.5 OS: freebsd6.2
Private report: No CVE-ID:
 [2008-03-24 05:09 UTC] 24498936 at qq dot com
Description:
------------
os is freebsd6.2 + apache2.26

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/mssql.so' - Cannot open "/usr/local/lib/php/20060613/mssql.so" in Unknown on line 0 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/odbc.so' - Cannot open "/usr/local/lib/php/20060613/odbc.so" in Unknown on line 0 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/sqlite.so' - /usr/local/lib/php/20060613/sqlite.so: Undefined symbol "spl_ce_Countable" in Unknown on line 0 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/bz2.so' - Cannot open "/usr/local/lib/php/20060613/bz2.so" in Unknown on line 0 
PHP Warning:  Module 'ctype' already loaded in Unknown on line 0 
PHP Warning:  Module 'pcre' already loaded in Unknown on line 0 
PHP Warning:  Module 'SimpleXML' already loaded in Unknown on line 0 
PHP Warning:  Module 'dom' already loaded in Unknown on line 0 
PHP Warning:  Module 'fileinfo' already loaded in Unknown on line 0 
PHP Warning:  Module 'ftp' already loaded in Unknown on line 0 
PHP Warning:  Module 'gd' already loaded in Unknown on line 0 
PHP Warning:  Module 'gettext' already loaded in Unknown on line 0 
PHP Warning:  Module 'iconv' already loaded in Unknown on line 0 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/mssql.so' - Cannot open "/usr/local/lib/php/20060613/mssql.so" in Unknown on line 0 
PHP Warning:  Module 'mysql' already loaded in Unknown on line 0 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/mysqli.so' - Cannot open "/usr/local/lib/php/20060613/mysqli.so" in Unknown on line 0 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/odbc.so' - Cannot open "/usr/local/lib/php/20060613/odbc.so" in Unknown on line 0 
PHP Warning:  Module 'PDO' already loaded in Unknown on line 0 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/pgsql.so' - Cannot open "/usr/local/lib/php/20060613/pgsql.so" in Unknown on line 0 
PHP Warning:  Module 'posix' already loaded in Unknown on line 0 
PHP Warning:  Module 'session' already loaded in Unknown on line 0 
PHP Warning:  Module 'sockets' already loaded in Unknown on line 0 
PHP Warning:  Module 'tokenizer' already loaded in Unknown on line 0 
PHP Warning:  Module 'xml' already loaded in Unknown on line 0 
PHP Warning:  Module 'xmlreader' already loaded in Unknown on line 0 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/xmlrpc.so' - Cannot open "/usr/local/lib/php/20060613/xmlrpc.so" in Unknown on line 0 
PHP Warning:  Module 'xmlwriter' already loaded in Unknown on line 0 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/xsl.so' - Cannot open "/usr/local/lib/php/20060613/xsl.so" in Unknown on line 0 
PHP Warning:  Module 'zip' already loaded in Unknown on line 0 
PHP Warning:  Module 'pdo_mysql' already loaded in Unknown on line 0 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/curl.so' - Cannot open "/usr/local/lib/php/20060613/curl.so" in Unknown on line 0 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/bz2.so' - Cannot open "/usr/local/lib/php/20060613/bz2.so" in Unknown on line 0 
PHP Warning:  Module 'ctype' already loaded in Unknown on line 0 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/curl.so' - Cannot open "/usr/local/lib/php/20060613/curl.so" in Unknown on line 0 
PHP Warning:  Module 'pcre' already loaded in Unknown on line 0 
PHP Warning:  Module 'ctype' already loaded in Unknown on line 0 
PHP Warning:  Module 'pcre' already loaded in Unknown on line 0 
PHP Warning:  Module 'ctype' already loaded in Unknown on line 0 
PHP Warning:  Module 'pcre' already loaded in Unknown on line 0 
PHP Warning:  Module 'SPL' already loaded in Unknown on line 0 
PHP Warning:  Module 'dom' already loaded in Unknown on line 0 
PHP Warning:  Module 'filter' already loaded in Unknown on line 0 
PHP Warning:  Module 'ftp' already loaded in Unknown on line 0 
PHP Warning:  Module 'gd' already loaded in Unknown on line 0 
PHP Warning:  Module 'hash' already loaded in Unknown on line 0 
PHP Warning:  Module 'iconv' already loaded in Unknown on line 0 
PHP Warning:  Module 'json' already loaded in Unknown on line 0 
PHP Warning:  Module 'mysql' already loaded in Unknown on line 0 
PHP Warning:  Module 'openssl' already loaded in Unknown on line 0 
PHP Warning:  Module 'PDO' already loaded in Unknown on line 0 
PHP Warning:  Module 'pdo_sqlite' already loaded in Unknown on line 0 
PHP Warning:  Module 'posix' already loaded in Unknown on line 0 
PHP Warning:  Module 'session' already loaded in Unknown on line 0 
PHP Warning:  Module 'SQLite' already loaded in Unknown on line 0 
PHP Warning:  Module 'tokenizer' already loaded in Unknown on line 0 
PHP Warning:  Module 'zlib' already loaded in Unknown on line 0 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/bz2.so' - Cannot open "/usr/local/lib/php/20060613/bz2.so" in Unknown on line 0 
PHP Warning:  Module 'fileinfo' already loaded in Unknown on line 0 
PHP Warning:  Module 'gettext' already loaded in Unknown on line 0 
PHP Warning:  Module 'sockets' already loaded in Unknown on line 0 
PHP Warning:  Module 'xml' already loaded in Unknown on line 0 
PHP Warning:  Module 'xmlreader' already loaded in Unknown on line 0 
PHP Warning:  Module 'xmlwriter' already loaded in Unknown on line 0 
PHP Warning:  Module 'zip' already loaded in Unknown on line 0 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/bz2.so' - Cannot open "/usr/local/lib/php/20060613/bz2.so" in Unknown on line 0 
PHP Warning:  Module 'ctype' already loaded in Unknown on line 0 
PHP Warning:  Module 'pcre' already loaded in Unknown on line 0 
PHP Warning:  Module 'SimpleXML' already loaded in Unknown on line 0 
PHP Warning:  Module 'SPL' already loaded in Unknown on line 0 
PHP Warning:  Module 'dom' already loaded in Unknown on line 0 
PHP Warning:  Module 'filter' already loaded in Unknown on line 0 
PHP Warning:  Module 'ftp' already loaded in Unknown on line 0 
PHP Warning:  Module 'gd' already loaded in Unknown on line 0 
PHP Warning:  Module 'gettext' already loaded in Unknown on line 0 
PHP Warning:  Module 'hash' already loaded in Unknown on line 0 
PHP Warning:  Module 'iconv' already loaded in Unknown on line 0 
PHP Warning:  Module 'json' already loaded in Unknown on line 0 
PHP Warning:  Module 'mysql' already loaded in Unknown on line 0 
PHP Warning:  Module 'openssl' already loaded in Unknown on line 0 
PHP Warning:  Module 'PDO' already loaded in Unknown on line 0 
PHP Warning:  Module 'pdo_sqlite' already loaded in Unknown on line 0 
PHP Warning:  Module 'posix' already loaded in Unknown on line 0 
PHP Warning:  Module 'session' already loaded in Unknown on line 0 
PHP Warning:  Module 'sockets' already loaded in Unknown on line 0 
PHP Warning:  Module 'SQLite' already loaded in Unknown on line 0 
PHP Warning:  Module 'tokenizer' already loaded in Unknown on line 0 
PHP Warning:  Module 'xml' already loaded in Unknown on line 0 
PHP Warning:  Module 'xmlreader' already loaded in Unknown on line 0 
PHP Warning:  Module 'xmlwriter' already loaded in Unknown on line 0 
PHP Warning:  Module 'zip' already loaded in Unknown on line 0 
PHP Warning:  Module 'zlib' already loaded in Unknown on line 0 
PHP Warning:  Module 'ctype' already loaded in Unknown on line 0 
PHP Warning:  Module 'pcre' already loaded in Unknown on line 0 
PHP Warning:  Module 'SimpleXML' already loaded in Unknown on line 0 
PHP Warning:  Module 'SPL' already loaded in Unknown on line 0 
PHP Warning:  Module 'dom' already loaded in Unknown on line 0 
PHP Warning:  Module 'fileinfo' already loaded in Unknown on line 0 
PHP Warning:  Module 'filter' already loaded in Unknown on line 0 
PHP Warning:  Module 'ftp' already loaded in Unknown on line 0 
PHP Warning:  Module 'gd' already loaded in Unknown on line 0 
PHP Warning:  Module 'gettext' already loaded in Unknown on line 0 
PHP Warning:  Module 'hash' already loaded in Unknown on line 0 
PHP Warning:  Module 'iconv' already loaded in Unknown on line 0 
PHP Warning:  Module 'json' already loaded in Unknown on line 0 
PHP Warning:  Module 'mbstring' already loaded in Unknown on line 0 
PHP Warning:  Module 'mysql' already loaded in Unknown on line 0 
PHP Warning:  Module 'openssl' already loaded in Unknown on line 0 
PHP Warning:  Module 'PDO' already loaded in Unknown on line 0 
PHP Warning:  Module 'pdo_sqlite' already loaded in Unknown on line 0 
PHP Warning:  Module 'posix' already loaded in Unknown on line 0 
PHP Warning:  Module 'session' already loaded in Unknown on line 0 
PHP Warning:  Module 'sockets' already loaded in Unknown on line 0 
PHP Warning:  Module 'SQLite' already loaded in Unknown on line 0 
PHP Warning:  Module 'tokenizer' already loaded in Unknown on line 0 
PHP Warning:  Module 'xml' already loaded in Unknown on line 0 
PHP Warning:  Module 'xmlreader' already loaded in Unknown on line 0 
PHP Warning:  Module 'xmlwriter' already loaded in Unknown on line 0 
PHP Warning:  Module 'zip' already loaded in Unknown on line 0


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-03-25 13:15 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 24 19:01:53 2014 UTC