php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44422 Server Crash with php5isapi
Submitted: 2008-03-12 18:35 UTC Modified: 2008-10-21 11:33 UTC
Votes:5
Avg. Score:4.8 ± 0.4
Reproduced:5 of 5 (100.0%)
Same Version:3 (60.0%)
Same OS:5 (100.0%)
From: drew at tribalectic dot com Assigned:
Status: Wont fix Package: IIS related
PHP Version: 5.2.5 OS: Windows 2003 Server
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2008-03-12 18:35 UTC] drew at tribalectic dot com
Description:
------------
PHP 5.2.3 was causing server crashes every so often on the application pool. So, we just upgreaded to 5.2.5 and are still getting application crashes. Here's my backtrace...

php5isapi!php_isapi_report_exception+17     1216f970     00000033     031bfd58    
php5isapi!HttpExtensionProc+2e0     01088d20     01087a28     010886b0    
w3isapi!ProcessIsapiRequest+100     01088c98     01cc1de0     1216fe50    
w3core+68ff     00000000     00000000     01087a28    
w3core+67e0     1216fee8     01087a28     00000000    
w3core+6764     01087a28     00000000     1216fec4    
w3core+66f4     01087a30     01087a28     00000001    
w3core+66ae     00000001     1216fee8     0026bc78    
w3core+6648     00000000     00000000     00000000    
w3core+2264     00000000     00000000     00000000    
w3core+65ea     01086f60     01086f60     5a361650    
w3dt!UlAtqAllocateMemory+16f     0000051e     00000000     01086f64    
w3dt!UlAtqAllocateMemory+19a     00000000     0000051e     01086f64    
w3tp!THREAD_POOL::PostCompletion+c9     00000000     109d7bb0     5a300000    
w3tp!THREAD_POOL::~THREAD_POOL+153     00268700     00000000     00000000    
w3tp+1da9     109d7bb0     00000000     00000000    
kernel32!GetModuleHandleA+df     5a301d70     109d7bb0     00000000    

PHP5ISAPI!PHP_ISAPI_REPORT_EXCEPTION+17In w3wp__PID__2444__Date__03_12_2008__Time_12_01_04PM__156__Second_Chance_Exception_C0000005.dmp the assembly instruction at php5isapi!php_isapi_report_exception+17 in \\?\C:\PHP\php5isapi.dll from The PHP Group has caused an access violation exception (0xC0000005) when trying to read from memory location 0x00000090 on thread 0

Module Information 
Image Name: \\?\C:\PHP\php5isapi.dll   Symbol Type:  PDB 
Base address: 0x01cc0000   Time Stamp:  Thu Nov 08 21:18:54 2007  
Checksum: 0x00000000   Comments:  Thanks to Andi Gutmans, Zeev Suraski 
COM DLL: False   Company Name:  The PHP Group 
ISAPIExtension: True   File Description:  ISAPI 
ISAPIFilter: True   File Version:  5.2.5.5 
Managed DLL: False   Internal Name:  php5isapi.dll 
VB DLL: False   Legal Copyright:  Copyright ? 1997-2007 The PHP Group 
Loaded Image Name:  php5isapi.dll   Legal Trademarks:  PHP 
Mapped Image Name:     Original filename:  php5isapi.dll 
Module name:  php5isapi   Private Build:   
Single Threaded:  False   Product Name:  PHP php5isapi.dll 
Module Size:  28.00 KBytes   Product Version:  5.2.5 
Symbol File Name:  E:\PHP Debug Symbols\php5isapi.pdb   Special Build:  & 

I've seen errors like this before but no solutions, HELP!

   -Drew


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-03-12 22:33 UTC] drew at tribalectic dot com
Upgrading is slightly time consuming and difficult, does the windows installer overwrite my php.ini file? Can I just use that to upgrade or do I need to manually overwrite all files? Is the problem I have described fixed in the latest version? This is a production site so I am a little worried about tinkering too much.

   -Drew
 [2008-03-17 20:00 UTC] drew at tribalectic dot com
I have upgraded to 5.2.6RC3-dev and the problems continue. This is killing our server with these resets, we really need HELP and the server is live with lots of traffic so the sooner the better! Here is the latest backtrace:

In w3wp__PID__1348__Date__03_17_2008__Time_12_52_29PM__578__First chance exception 0XC0000005.dmp the assembly instruction at msvcrt!_strdup+12 in C:\WINDOWS\system32\msvcrt.dll from Microsoft Corporation has caused an access violation exception (0xC0000005) when trying to read from memory location 0x00000000 on thread 126

Thread 126 - System ID 5804

Entry point   w3tp!THREAD_MANAGER::ThreadManagerThread 
Create time   3/17/2008 12:52:23 PM 
Time spent in user mode   0 Days 00:00:00.00 
Time spent in kernel mode   0 Days 00:00:00.00 

This thread is calling an ISAPI Filter php5isapi

Function   Source 
msvcrt!_strdup+12    
php5ts!WspiapiLegacyGetNameInfo+23f    
ntdll!RtlCreateHeap+6bd    
php5ts!zif_bcdiv+c4    
php5isapi!HttpExtensionProc+3a    
w3core!W3_METADATA::GetAndRefVrAccessToken+3b    
0x4b81fbcc    
w3core!W3_CONTEXT::InternalDetermineHandler+6ee    
0x80000000`00000000

Let me know, thank you!

   -Drew
 [2008-07-13 06:16 UTC] d dot runkel at nanotron dot com
We have the same here using Server 2008 (IIS7) / PHP 5.2.6.

I lowered the Idle-Timeout of the default App Pool from 20min to 1 min. 
Whenever i browse a Page containing phpinfo as a single line and wait for the timeout events 
  5186 ( Apppool idle shutdown) 
  5009 (Appool crash due to php5isapi dll heap problem)
are logged.

I just tested with actual snapshot 5.2.7 and the problem persists.

Any updates on this ?
 [2008-10-21 11:33 UTC] jani@php.net
Save yourself a lot of trouble and start using FastCGI instead of ISAPI module. It actually works..
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon May 25 12:01:23 2020 UTC