php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44138 zlib.compression causes blank screens
Submitted: 2008-02-16 17:36 UTC Modified: 2008-03-13 14:32 UTC
From: owner at dragon-hearts dot net Assigned:
Status: Not a bug Package: Zlib related
PHP Version: 5.2.5 OS: CentOs 4
Private report: No CVE-ID: None
 [2008-02-16 17:36 UTC] owner at dragon-hearts dot net
Description:
------------
When zlib.compression is enabled randomly pages will appear blank (a completely white screen) this happens on Internet Explorer 6 and 7, Firefox 2 and in Safari 3 a similar issue happens but it shows an error message of "bad server response (NSURLErrorDomain:-1011".

Without zlib.compression everything loads fine.

When using apache's mod_deflate to compress output everything works fine.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-03-11 22:39 UTC] jani@php.net
PLEASE read the instructions found at http://bugs.php.net/how-to-report.php and provide the basic information needed.
 [2008-03-11 23:01 UTC] owner at dragon-hearts dot net
I have read the instructions
What I did

Enabled zlib.compression

What happens

zlib.compression is enabled - sometimes pages come up blank

What should happen

Pages should load normally

If you rummage through the bug database there appear to have been bugs similar reported for previous PHP versions which haven't been fixed and ignored.
 [2008-03-13 12:32 UTC] jani@php.net
And because you're refusing to give even the most basic information about how you configured PHP / what SAPI you're using / what webserver / etc., this report will soon join the others and be ignored..

Output buffering can be misconfigured in several ways, so please, check the php.ini-dist file and the comments in it for more information.
These directives are relevant at least: output_buffering, output_handler, zlib.output_compression. And what _exactly_ you put as the values? And have you checked the webserver / other logs what really happens when you get 'blank screen' ???

 [2008-03-13 12:38 UTC] owner at dragon-hearts dot net
The web server is apache 2.2.6, configured as FCGI

php.ini settings

output_buffering = 4096
output_handler isn't defined
zlib.output_compression = on
zlib.output_compression_level = 5


Other logs don't show anything out of the ordinary.

Maybe you should add some optional boxes to bug report pages asking for webserver and configuration.
 [2008-03-13 13:07 UTC] jani@php.net
Works fine for me. What exactly are those pages that randomly appear as blank? Have you checked e.g. with firebug what the headers are that the server sends then? Are you sure there is not crash happening..? And have you disabled all compression modules in apache conf?
 [2008-03-13 13:15 UTC] owner at dragon-hearts dot net
The pages can be any php page, I've not checked with firebug, I'm sure it's not a crash happening or I'd have logs of it. All compression modules were disabled when zlib.compression was enabled.
 [2008-03-13 13:33 UTC] jani@php.net
So check the headers when you get a blank screen then.
 [2008-03-13 13:34 UTC] jani@php.net
And also what the browser did receive (as in "show source" :)
 [2008-03-13 13:50 UTC] owner at dragon-hearts dot net
The source is blank, I don't use this configuration anymore so I can't test it I changed the configuration to solve the problem so I can't check the headers.
 [2008-03-13 14:32 UTC] jani@php.net
You can't test, I can't reproduce -> case closed. 
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Sep 19 02:01:25 2020 UTC