php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44137 Compile will fail with MySQL-5.1.23-rc
Submitted: 2008-02-16 07:20 UTC Modified: 2008-02-24 06:58 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: jari dot tuomoja at gmail dot com Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: 5.2.5 OS: Fedora Core 6, x86_64
Private report: No CVE-ID: None
 [2008-02-16 07:20 UTC] jari dot tuomoja at gmail dot com
Description:
------------
When compiling MySQL 5.1.23-rc, option --with-mysqli=/youd/dir/to/mysql_config will always fail.

MySQL and PDO are working ok but mysqli is failing. With MySQL 5.1.22-rc everything works well.

MySQL answered that this is a bug in PHP, not in MySQL. MySQL server is working okay.

Reproduce code:
---------------
Compile php-5.2.5 with mysqli -option.

Expected result:
----------------
Compile ok

Actual result:
--------------
Error messages and compile will exit

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-02-16 18:11 UTC] johannes@php.net
Can't reproduce, please give the relevant error messages and, if possible, the link to MySQL Bug. Thanks.
 [2008-02-17 07:08 UTC] jari dot tuomoja at gmail dot com
Here is the configure script:

./configure --with-zlib-dir=/usr/local/ --enable-shared --enable-static --disable-short-tags --with-apxs2=/usr/local/apache2/bin/apxs --with-bz2 --with-mysql=/usr/local/mysql --with-mysqli=/usr/local/mysql/bin/mysql_config --with-pdo-mysql=/usr/local/mysql/ --enable-exif --with-gd=/usr/local/ --with-freetype-dir=/usr/local/include/freetype2/ --with-png-dir=/usr/local/include/ --enable-mbstring=all --enable-gd-native-ttf --enable-calendar --enable-zip --enable-sqlite-utf8 --with-openssl --with-mcrypt --with-mhash --with-pear --enable-soap --enable-mod-charset --enable-ftp --with-xsl


./configure is succeed but when running make, then come this:

/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c: In function 'zif_mysqli_change_user':
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:420: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:420: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:420: error: 'NET' has no member named 'last_error'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c: In function 'zif_mysqli_kill':
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1152: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1152: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1152: error: 'NET' has no member named 'last_error'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c: In function 'zif_mysqli_ping':
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1333: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1333: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1333: error: 'NET' has no member named 'last_error'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c: In function 'zif_mysqli_prepare':
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1376: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1377: error: 'NET' has no member named 'last_error'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1383: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1383: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1383: error: 'NET' has no member named 'last_error'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c: In function 'zif_mysqli_real_connect':
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1453: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1454: error: 'NET' has no member named 'last_error'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c: In function 'zif_mysqli_real_query':
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1492: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1492: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1492: error: 'NET' has no member named 'last_error'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c: In function 'zif_mysqli_select_db':
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1761: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1761: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:1761: error: 'NET' has no member named 'last_error'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c: In function 'zif_mysqli_store_result':
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:2058: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:2058: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:2058: error: 'NET' has no member named 'last_error'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c: In function 'zif_mysqli_use_result':
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:2112: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:2112: error: 'NET' has no member named 'last_errno'
/usr/src/php-5.2.5/ext/mysqli/mysqli_api.c:2112: error: 'NET' has no member named 'last_error'
make: *** [ext/mysqli/mysqli_api.lo] Error 1


I hope this helps.


--JARI--
 [2008-02-17 07:12 UTC] jari dot tuomoja at gmail dot com
MySQL have compiled with following options:

./configure --prefix=/usr/local/mysql --enable-shared --enable-static --without-server

Server has all latest libraries in use, they are installed with yum from Fedora reposity.

--JARI--
 [2008-02-18 15:27 UTC] uw@php.net
ACK, please try the latest versions. I recall similar issues not on FC6 but in general. There have been changes to some structures. Let me ping Andrey, he might know more.

Ulf
 [2008-02-18 19:41 UTC] uw@php.net
A little more info: we are discussing this internally at MySQL. Its possible that the change which has caused this (unintended) problem will be reverted soon.
 [2008-02-23 23:14 UTC] james dot j dot hackett at gmail dot com
This isn't a fedora problem, I am experiencing the same bug on Debian.
 [2008-02-24 01:01 UTC] jani@php.net
And it's not PHP problem but Mysql problem since they broke the BC in their libs/headers. :)
 [2008-02-24 01:03 UTC] jani@php.net
And please, in the future don't report bugs caused by some 3rd party library here which isn't even released as stable yet.
 [2008-02-24 06:58 UTC] jari dot tuomoja at gmail dot com
I submitted this bug to here because in MySQL bug library they said that this is not MySQL related bug - MySQLi is under PHP dev. But now it seems that this bug is MySQL related bug.

Like I said already: everything works with previous version of MySQL (5.1.22-RC) but not with the newest one (5.1.23-RC).

I think that Release Candidate should be more stable than beta -version and if there is bug with RC -version, it should be repaired asap. And when MySQL is one letter of LAMP and PHP is another letter, I think this is quite important bug.

But I hope that PHP & MySQL communities will find solution for this bug per now.

--JT--
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jan 25 01:01:23 2021 UTC