php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44126 pear config-set works, but pecl config-set does not
Submitted: 2008-02-15 01:42 UTC Modified: 2008-02-15 06:23 UTC
From: mpb dot mail at gmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.2.5 OS: Linux 2.6
Private report: No CVE-ID: None
 [2008-02-15 01:42 UTC] mpb dot mail at gmail dot com
Description:
------------
I am able to set php_ini via pear, but not via pecl, as follows:

$ pecl config-set php_ini /home/gobo/Programs/PHP/5.2.5/lib/php.ini 
config-set (php_ini, /home/gobo/Programs/PHP/5.2.5/lib/php.ini, user) failed, channel pecl.php.net

exit  1
 
$ pear config-set php_ini /home/gobo/Programs/PHP/5.2.5/lib/php.ini 
config-set succeeded

I would expect to be able to do config-set via either pear or pecl, as "pecl help" lists config-set as a valid pecl command.

Thanks!



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-02-15 06:23 UTC] cellog@php.net
I am closing this bug as bogus because it was reported in the wrong bugtracker, not because of any problems in the report.  The bug tracker for PEAR is listed below.

This is a valid bug, but may be fixed.  Please try:

pear upgrade PEAR

and then try the pecl config-set again.  If the problem persists, please report at http://pear.php.net/bugs/report.php?package=PEAR

For future reference, this is the bugtracker for the PEAR installer pear/pecl commands.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Aug 16 10:05:45 2022 UTC