php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #44107 [JA] mt_srand() - ChangeLog Since 5.2.1
Submitted: 2008-02-13 01:55 UTC Modified: 2010-10-24 04:56 UTC
From: kentaro at ranvis dot com Assigned: takagi (profile)
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2008-02-13 01:55 UTC] kentaro at ranvis dot com
Description:
------------
The Japanese translation of mt_srand()'s "ChangeLog Since 5.2.1" is not correct.
It seems to have confused seeds and values.

Reproduce code:
---------------
http://www.php.net/manual/ja/function.mt-srand.php

The Mersenne Twister implementation in PHP now uses a new seeding algorithm by Richard Wagner.
Identical seeds no longer produce the same sequence of values they did in previous versions.
This behavior is not expected to change again, but it is considered unsafe to rely upon it nonetheless.

Expected result:
----------------
PHP の Mersenne Twister 実装は、Richard Wagner による新たなシード生成アルゴリズムを使用するようになりました。
これまでのバージョンと同じシード値で同じ乱数列が生成されることはなくなりました。
この振る舞いが再び変わる見込みはありませんが、それに関わらずこの振る舞いに頼るのは安全ではありません。

Actual result:
--------------
PHP の Mersenne Twister 実装は、Richard Wagner による新たなシード生成アルゴリズムを使用するようになりました。
これまでのバージョンのように、同じ値のシーケンスで同じシードが生成されることはなくなりました。
この振る舞いが今後変わることはないでしょうが、この振る舞いに頼ってしまってはいけません。

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-10-23 13:01 UTC] kalle@php.net
-Type: Bug +Type: Documentation Problem
 [2010-10-24 04:55 UTC] takagi@php.net
Automatic comment from SVN on behalf of takagi
Revision: http://svn.php.net/viewvc/?view=revision&revision=304676
Log: fixed bug #44107.
 [2010-10-24 04:56 UTC] takagi@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: takagi
 [2010-10-24 04:56 UTC] takagi@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

http://news.php.net/php.doc.ja/2834
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Jul 16 18:01:25 2020 UTC