php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #44105 $_SERVER['REDIRECT_URL'] content changed
Submitted: 2008-02-12 13:19 UTC Modified: 2008-11-07 12:18 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (50.0%)
From: michaells at cytainment dot de Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2008-02-12 13:19 UTC] michaells at cytainment dot de
Description:
------------
Since version 5.2.5 the value of $_SERVER['REDIRECT_URL'] contained the absolute path requested (without protocol, host and domain). E.g. working with .htaccess setting ErrorDocument 404 to index.php and checking in the PHP-script, how to handle nonexisting call ( if( preg_match('/vcard\.html$/',$_SERVER['REDIRECT_URL']))...) worked fluently. Since 5.2.5 the content of this key is now the absolute path of the script redirected to.
Maybe behaviour changed as wanted, but for sure, it's not documented.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-11-07 12:18 UTC] vrana@php.net
This variable is set by Apache, not PHP.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon May 25 03:01:24 2020 UTC