php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44078 my_thread_global_end()
Submitted: 2008-02-08 19:30 UTC Modified: 2008-02-08 21:32 UTC
From: land_118 at rogers dot com Assigned:
Status: Closed Package: MySQL related
PHP Version: 5.2CVS-2008-02-08 (snap) OS: Windows 2000/SP4
Private report: No CVE-ID:
 [2008-02-08 19:30 UTC] land_118 at rogers dot com
Description:
------------
Just downloaded php5.2.5 zip today (Feb 8/2008). Got the same error which was reported as closed.

After manual installation, I copied the php.ini-recommended file to php.ini and changed the following lines:
1)   extension_dir = "./"     to  extension_dir = "./ext"
2)   ;extension=php_mysql.dll to  extension=php_mysql.dll

When I enter 'php -h' at the command line, it shows the help text then pauses. After a few seconds I get the message:
  "Error in my_thread_global_end(): 1 threads didn't exit"
followed by the command prompt.

By restoring either of the two lines in the php.ini file, the problem goes away.

I've tried both the stable 5.2 and latest 5.2 snaps version and also tried the latest 5.3 snaps.

Unable to find solution in bug search.

Reproduce code:
---------------
php -h

Expected result:
----------------
expected not to see the message or a pause.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-02-08 21:32 UTC] land_118 at rogers dot com
Downloading the latest libaries from the MySQL web site resolved the problem.

Was using MySQL 5.0.51a. Used libaries from MySQL 5.0.27.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 25 07:02:14 2014 UTC