php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #43879 PHP_INI_PERDIR support in registry
Submitted: 2008-01-17 16:46 UTC Modified: 2016-06-13 13:17 UTC
Votes:8
Avg. Score:5.0 ± 0.0
Reproduced:7 of 8 (87.5%)
Same Version:4 (57.1%)
Same OS:7 (100.0%)
From: phprequests at iis-aid dot com Assigned: cmb (profile)
Status: Duplicate Package: *Configuration Issues
PHP Version: 5.2.5 OS: Windows 2003 Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: phprequests at iis-aid dot com
New email:
PHP Version: OS:

 

 [2008-01-17 16:46 UTC] phprequests at iis-aid dot com
Description:
------------
Would it be possible to add support for setting PHP_INI_PERDIR values in the Windows registry the same as PHP_INI_USER values as per documented in the link below?

http://us2.php.net/configuration.changes

This has been brought up way back in 2005 in this report;

http://bugs.php.net/bug.php?id=32337&edit=2

Problem is when using PHP on IIS the registry method is the only way I am aware of for setting per directory/localised PHP environment values without using the ini_set() function which is not usally a viable option.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-06-13 13:17 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Package: Feature/Change Request +Package: *Configuration Issues -Assigned To: +Assigned To: cmb
 [2016-06-13 13:17 UTC] cmb@php.net
> This has been brought up way back in 2005 in this report;
>
> http://bugs.php.net/bug.php?id=32337&edit=2

So this ticket is a duplicate of request #32337.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 29 02:01:24 2020 UTC