php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43755 php_admin_value include_path on one VirtualHost affects all VirtualHosts
Submitted: 2008-01-04 23:10 UTC Modified: 2008-03-14 12:00 UTC
Votes:3
Avg. Score:5.0 ± 0.0
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:2 (66.7%)
From: andrew-php at thepenry dot net Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5.2.5 OS: centos4
Private report: No CVE-ID:
 [2008-01-04 23:10 UTC] andrew-php at thepenry dot net
Description:
------------
Using php_admin_value include_path in one VirtualHost prevents using set_include_path() in another VirtualHost.

The documentation is unclear about whether this is the correct behavior, but it seems like php_admin_value should only effect the VirtualHost it was declared in, not the entire server.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-01-10 05:20 UTC] andrew-php at thepenry dot net
This bug seems to be the same as:
http://bugs.php.net/bug.php?id=43677
 [2008-02-07 00:46 UTC] jani@php.net
Duplicate of bug #43677
 [2008-03-14 12:00 UTC] jani@php.net
And this should be fixed now in CVS and in soon to be released 5.2.6. 
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 07:02:06 2014 UTC