php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43699 jd Functions not invertable
Submitted: 2007-12-28 18:53 UTC Modified: 2007-12-28 19:41 UTC
From: phpexpert at prologon dot ch Assigned:
Status: Not a bug Package: Calendar related
PHP Version: 5.2CVS-2007-12-28 (CVS) OS: LINUX
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: phpexpert at prologon dot ch
New email:
PHP Version: OS:

 

 [2007-12-28 18:53 UTC] phpexpert at prologon dot ch
Description:
------------
Cascading
unixtojd and jdtounix
does not produce the original input.

Reproduce code:
---------------
jdtounix(unixtojd(1198450800))



Expected result:
----------------
since these are inverse functions, one would expect
an unchanged result, independantly of localtime and daylightsaving issues:
1198450800

Actual result:
--------------
1198454400
which is one hour offsetresults in:
1198454400
which is one hour offset.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-12-28 19:41 UTC] johannes@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

\"The time returned is localtime (and not GMT).\" http://php.net/jdtounix
Whereas unixtojd assumes GMT timestamps, unfortunate, but changing it would create problems for people who rely on this behavior.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jun 03 01:01:25 2020 UTC