php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43639 php-5.2.5-win32-installer.msi stops before it is finished.
Submitted: 2007-12-19 21:17 UTC Modified: 2008-10-22 17:42 UTC
Votes:41
Avg. Score:4.7 ± 0.8
Reproduced:31 of 33 (93.9%)
Same Version:18 (58.1%)
Same OS:14 (45.2%)
From: erik dot kullberg at telia dot com Assigned: jmertic
Status: Closed Package: Windows Installer
PHP Version: 5.2.5 OS: Windows Vista
Private report: No CVE-ID:
 [2007-12-19 21:17 UTC] erik dot kullberg at telia dot com
Description:
------------
I try to install PHP_5.2.5 by use of php-5.2.5-win32-installer.msi, but it stops before it is finished and delivers the following message:

"There is a problem with this Windows Installer Package. A script required for this install to complete could not be run. Contact your support personnel or package vendor."

I tried to run the installation with the wanted additions (MySQL and GD) and without any additions at all - the result is the same.

System: Windows Vista, version 6.0 "Home Premium".
Server: Apache 2.2.6

I cannot extract a cure from the answers to those similar questions in the database. Is there one? Or maybe a prognosis for a solution?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-12-24 13:31 UTC] lehelkovach at hotmail dot com
I also have the same problem having Vista Home Premium 32bit.  I tried the installer provided in the reply but i got the same problem of the script not being able to run.
 [2007-12-30 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2008-01-06 12:49 UTC] sean dot mccleary at gmail dot com
Same problem here.  More info from the Windows event viewer:

Product: PHP 5.2.5 -- Error 1720. There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor.  Custom action unconfigApache script error -2146828218, Microsoft VBScript runtime error: Permission denied Line 142, Column 5,
 [2008-01-06 12:53 UTC] sean dot mccleary at gmail dot com
Same problem with 5.2.6-dev, by the way.
 [2008-01-06 13:56 UTC] sean dot mccleary at gmail dot com
Found a work-around.

Create a batch file to run the installer, and run the batch file as administrator.

Batch file should contain the single line:

msiexec /i C:\php-5.2.5-win32-installer.msi

Save it, right-click on it, run as administrator.
 [2008-02-16 17:57 UTC] davkalman at gmail dot com
This is not really a bug, just that the installer needs to be run as administrator.

When Right-clicking, Vista does not propose "Run as administrator" for MSI files. To correct this, modify the registry as follow: 

http://juice.altiris.com/download/1382/msi-run-as-administrator-context-menu-for-vista
 [2008-02-22 04:06 UTC] jhwanginet at hotmail dot com
The MSIEXEC/I batch file solved the "unable to run script" error for me.  But if you rerun the batch file to add/remove some extensions, then you get that error again.

Even after installation now without error, including certain extensions still crash PHP, for example, maybe,

pspell
Oracle 8
svnclient
threads
 [2008-03-04 19:39 UTC] markinoxford555 at yahoo dot co dot uk
Polite request... Is there any chance the batch file workaround could be added to the documentation? It is not obvious - it's no good just being logged on as administrator - you really do have to use the batch file, right click, and run as administrator.

You can say it's not a bug all you like, but the fact is that Windows Vista users simply can't install PHP without literally hours of frustration and searching here for solutions. Either decide that PHP isn't available under Windows Vista :-(  or add this trick to the documentation or, even better, change the installer so that it works without any trickery.

Please don't just say it's not a bug - as far as the user is concerned, it simply doesn't work, not give any indication of why it doesn't work, and that, in my mind, is a bug. Sorry!
 [2008-04-04 22:09 UTC] nospam at gmail dot com
I've having the same problem here and after running msiexec with logging options on, it seems that it fails because it "Could not access VBScript runtime for custom action".

Very frustrating bug, especially since you can't, by default, run MSI packages with administrator rights.

This is most likely a bug with the actual MSI package or packaging application.
 [2008-04-04 22:28 UTC] nospam at gmail dot com
You'd never believe it, but just going to c:\windows\system32 and running regsvr32 vbscript.dll fixed the MSI problem. Wow, go figure.
 [2008-05-08 10:13 UTC] pomax at nihongoresources dot com
installer feature suggestion: add a check to see if VBscript is a registered and running service, and break off the install if it is not detected. This should fix everyone's problems on Vista, Windows Server 2008, as well as XP installs where people decided to turn off any service they do not use themselves.

- MK
 [2008-05-21 23:20 UTC] hailstrike at libero dot it
It is terrible. I have same problem on Windows 2003 server r2 enterprise sp2 x64 with all updates and IIS6, when I try to install php-5.2.6-win32-installer.msi installer give me same error.
 [2008-07-08 00:13 UTC] rbsfou at gmail dot com
XP Pro SP3:

Custom action configIIS4 script error -2146828235, Microsoft VBScript runtime error: File not found Line 182, Column 9

I also cannot do the RunAS trick, as i am on SP3.

Does anyone actually use php on iis4 (nt? 98?) nowadays?
 [2008-07-26 19:02 UTC] tamasmatrai at yahoo dot com

 [2008-08-10 03:32 UTC] davis1089 at mint dot us dot to
I can confirm this bug in the installer!

My system is Norwegian, and uses , as decimal point, and when i changed regional options to english as "tamasmatrai" pointed out, installer finished successfully.
 [2008-08-11 14:18 UTC] paour at free dot fr
Hello,
same bug in french system (decimal separator is comma)
Script run with dot separator.
Nicolas
 [2008-08-24 01:03 UTC] nospam at gmail dot com
I'd like to confirm that this error occurs on 32-bit Vista systems in Dutch locale, also.

Running the installer from a batch as suggested above successfully executed the installation, however.
 [2008-09-08 11:40 UTC] pdanailov at yahoo dot com
I have the same problem. My system is 
Win XP Prof SP2, PHP 5.2.6 and PHP 5.2.7
Bulgarian settings changed to English for the decimal separator
None of the solutions worked. PHP Sucks:((((
 [2008-09-10 10:22 UTC] stonesben at googlemail dot com
This is disgusting. No workaround since 2007. Lazy or incompetent at fixing bugs?
 [2008-09-10 11:33 UTC] pajoye@php.net
Having this bug assigned to the installer maintainer will help to actually get it solved. Especially when so many different problems are discussed within the same bug.
 [2008-09-11 11:59 UTC] llucenic at inmail dot sk
My Win XP SP2 with Slovak locales - the same installer problem. After I changed the locales (regional settings) to English (United States), the installation worked fine even w/o the need to run as administrator.
Thank you Tamas for your insight. Helped a lot.

Ludo Lucenic
 [2008-09-18 01:52 UTC] kfou at free dot fr
I've generated a fixed installer that you can download from http://kfou.free.fr/php/php-5.2.6-win32-installer.msi.

Or you can download the original installer from php.net and modify it using Orca to extract the (faulty) script PHPInstallerScripts.vbs, patch it (using http://kfou.free.fr/php/PHPInstallerScripts.patch) and re-import it again using Orca.

Kamel.
 [2008-09-21 06:35 UTC] cfaribault at presencenet dot ca
Hi all,

Tried 5.2.6 MSI installer from PHP's site as well as the one from "kfou at free dot fr" and both still give me the error. Trying to setup PHP as Apache 2.2.x Module. I'm on XP !SP3 English.

Also worth noting, I don't get any error in System Event Viewer.

I also want to note that everytime I run the installer (because I've also tried to set it up as Apache CGI as well), it adds the following block of text in httpd.conf:

#BEGIN PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
ScriptAlias /php/ "D:/Program Files/PHP/"
Action application/x-httpd-php "D:/Program Files/PHP/php-cgi.exe"
PHPIniDir "D:/Program Files/PHP/"
LoadModule php5_module "D:/Program Files/PHP/php5apache2_2.dll"
PHPIniDir "D:/Program Files/PHP/"
LoadModule php5_module "D:/Program Files/PHP/php5apache2.dll"
PHPIniDir "D:/Program Files/PHP/"
LoadModule php5_module "D:/Program Files/PHP/php5apache.dll"
#END PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL

Over time, I ended up with 4-5 such blocks, all commented but one. Not a problem but still annoying. But there is one problem... Apache won't start unless I comment all "PHPIniDir..." lines but one.

Finally, I'd like to point out that the changes made to httpd.conf don't include an association to .php files for application/x-httpd-php ("AddType application/x-httpd-php .php"). Once the installer is done (past the error message) and Apache restarted, I'm prompted for a file download when I try to access a php file. That may be what the script fails to do because of the error, I don't know... But in my present situation, it's something that it's not doing.

I guess that'll be enough for now! :)

Chris
 [2008-09-23 22:40 UTC] thomas dot j dot owens at gmail dot com
I believe this might be related to a bug I file last night at http://bugs.php.net/bug.php?id=46155
 [2008-09-25 18:11 UTC] jim dot keller at contextsolutions dot net
Turning off User Account Control in Vista fixes this problem. Start > Control Panel > (Classic View) > User Accounts > Turn User Account Control Off

My guess is that even though the installer is running as administrator, the scripts that run in the background are separate processes, and are therefore subject to "user account control". If you like the User Account Control feature, just re-enable it after install.
 [2008-10-05 09:16 UTC] bad_boy2k8 at msn dot com
hey i have installed php-5.2.5-win32 but what is that php for? is it for making website or what please tell me
 [2008-10-22 01:27 UTC] andreaslustigcom at gmail dot com
None of the suggestions worked for me. I spent 2 days on this by now. Dedicated box, brand new install (XP pro, SP3) with no result. Ridiculous and very unprofessional. I'm a programmer, too, but if I was to deliver this to my clients I'd be out of work in no time. If PHP/Zend wants to be taken seriously they need to improve their quality assurance process dramatically. 0/10 from me!
 [2008-10-22 17:42 UTC] jmertic@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

Should be much better in the 5.2 snaps, which will prompt for escalated privileges during the install.

There are also a few more lingering issues ( mostly because of VBScript custom actions in the installer ) that will be fixed hopefully by 5.3.

Thanks everyone for your understanding and feedback.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Tue Apr 25 14:01:39 2017 UTC