php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43489 Class synopsis return types are not links
Submitted: 2007-12-03 20:41 UTC Modified: 2008-01-10 21:41 UTC
From: ezyang@php.net Assigned: bjori
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: Windows Vista
Private report: No CVE-ID:
 [2007-12-03 20:41 UTC] ezyang@php.net
Description:
------------
Inside the generated class synopsis, return types for method are often classes. These classes should be linkified to point to their respective documentation page.

Reproduce code:
---------------
<fieldsynopsis>
     <modifier>readonly</modifier>
     <modifier>public</modifier>
     <type>DOMElement</type>
     <varname linkend="domdocument.props.documentelement">documentElement</varname>
    </fieldsynopsis>

Expected result:
----------------
DOMElement in generated output is link

Actual result:
--------------
Class name is not.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-12-04 09:44 UTC] bjori@php.net
See phpdotnet::format_type_text(), we should probably add a default case there that checks if class.$type exists - and if so, link to it.
 [2007-12-04 12:21 UTC] bjori@php.net
We should be consistent.. Either all <fieldsynopsis><type>s should be links or none...

Or maybe always link <type> if its a classname (methodparam, methodsynopsis, classsynopsisinfo..)?


 [2007-12-05 02:48 UTC] ezyang@php.net
I think a phpdotnet::format_type_text() change would work better, but that's just my opinion. We've never linked to the base PHP types, and I don't think we're about to start.
 [2008-01-10 21:41 UTC] bjori@php.net
This bug has been fixed in CVS. Since the websites are not directly
updated from the CVS server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.

objects and other pseudo types (mixed, callback..) in fieldsynopsis & methodparam now generate links, and methodsynopsis when not in classsynopsis.

 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 18:02:13 2014 UTC