php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43384 buildconf: Your version of autoconf likely contains buggy cache code.
Submitted: 2007-11-23 03:45 UTC Modified: 2007-11-24 12:21 UTC
From: kerplunk at kerplunk dot net Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.2.5 OS: CentOS 5.0
Private report: No CVE-ID: None
 [2007-11-23 03:45 UTC] kerplunk at kerplunk dot net
Description:
------------
I do not mean to offend anyone here, but this bug should not have been closed: http://bugs.php.net/bug.php?id=42417

If you read his last comment, it is exactly what I (and probably many others) are thinking:

"I don't want to sound rude (I really appreciate the response), but
shouldn't the build process be updated rather than recommend a 6 year
old version of autoconf? Is it planned for >2.13 support someday or did
the way autoconf works dramatically change? Just curious :)"

Is there an easier workaround for this? I would not have had to worry about this in the first place if you guys didn't mess up the configuring of PECL extensions. :(

At this point, I am not able to install the memcache PECL extension because of this "bug."

Thank you. I would appreciate a better explanation of this, or at least a workaround.

Reproduce code:
---------------
[root@server php-5.2.5]# ./buildconf --force
Forcing buildconf
using default Zend directory
buildconf: checking installation...
buildconf: autoconf version 2.59 (ok)
buildconf: Your version of autoconf likely contains buggy cache code.
           Running cvsclean for you.
           To avoid this, install autoconf-2.13.
[root@server php-5.2.5]#

Expected result:
----------------
It should work with the latest version of autoconf.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-24 12:21 UTC] jani@php.net
The best autoconf version ever is 2.13. Anything above is slow, buggy and utter crap. And as it works, why fix it? So just install the old version and you're done. Newer is not always better..

Free hint: You can have multiple autoconf versions around. Just set PHP_AUTOCONF and PHP_AUTOHEADER to point to the old versions, something like this:

# export PHP_AUTOCONF=/usr/bin/autoconf213
# export PHP_AUTOHEADER=/usr/bin/autoheader213

Then buildconf and phpize stuff will use the old (working) versions. :)
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Aug 09 17:05:47 2022 UTC