php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43284 Error "undefined symbol: zend_qsort" while starting Apache
Submitted: 2007-11-14 01:40 UTC Modified: 2007-11-14 03:06 UTC
From: marplatense at ubuntu dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5.2.5 OS: CentOS 4 64 bits
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: marplatense at ubuntu dot com
New email:
PHP Version: OS:

 

 [2007-11-14 01:40 UTC] marplatense at ubuntu dot com
Description:
------------
This bug is equal to http://bugs.php.net/bug.php?id=40524 (but it has a different php version and that's why I fill it again).


Reproduce code:
---------------
1- Using Apache/2.0.52 installed from CentOS repositories (updated Nov,13,2007)

2- PHP 5.2.5 compiled from source using this options:
./configure --prefix=/opt/php/php5.2.5 --exec-prefix=/opt/php/php5.2.5 --with-config-file-path=etc/httpd/conf.d --with-libdir=lib64 --with-gd --with-zlib=/usr --with-xmlrpc --with-oci8=/opt/oracle/orase/oracle/product/10.2.0/db_1 --with-apxs2=/usr/sbin/apxs --enable-sigchild --with-ttf=/usr/lib64 --enable-gd-native-ttf --enable-gd-imgstrttf --enable-gd-native-ttf --with-ttf-dir=/usr/local/lib --with-freetype-dir=/opt/freetype --with-zlib-dir=/usr/local/lib --with-png-dir=/usr/local/lib --with-jpeg-dir=/usr/local/lib --with-imap=/opt/imap/ --with-imap-ssl --with-mysql=/usr/bin --enable-mbstring --with-iconv --with-zlib --enable-sockets

3- Trying to start Apache:
# apachectl start


Expected result:
----------------
Apache starting ok.


Actual result:
--------------
Syntax error on line 6 of /etc/httpd/conf.d/php.conf:
Cannot load /usr/lib64/httpd/modules/libphp5.so into server: /usr/lib64/httpd/modules/libphp5.so: undefined symbol: zend_qsort

This is my /etc/httpd/conf.d/php.conf
***********************
#
# PHP is an HTML-embedded scripting language which attempts to make it
# easy for developers to write dynamically generated webpages.
#

LoadModule php5_module        /usr/lib64/httpd/modules/libphp5.so

#
# Cause the PHP interpreter to handle files with a .php extension.
#
AddType application/x-httpd-php .php .phtml
AddType application/x-httpd-php-source .phps

#
# Add index.php to the list of files that will be served as directory
# indexes.
#
DirectoryIndex index.php

***********************


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-14 03:06 UTC] marplatense at ubuntu dot com
Ok, so it seems it all boils down at running "make clean" if you're hitting this issue because it seems you recompiled too many times with configuration changes in the middle.
I found this information here: http://mai.abbastanza.info/post/6922232

I will try to post it the the docs so people can find this solution easier because in the first pages of a google search you find the problem but not the answer.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Mar 01 23:01:27 2024 UTC