php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #43233 SASL options do not load - Missing SASL support in windows builds
Submitted: 2007-11-10 08:40 UTC Modified: 2010-06-18 09:41 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:2 (100.0%)
From: scott dot thomas at inin dot com Assigned: pajoye
Status: Closed Package: LDAP related
PHP Version: 5.2.5 OS: Windows 2003 Server
Private report: No CVE-ID:
 [2007-11-10 08:40 UTC] scott dot thomas at inin dot com
Description:
------------
Using Windows 2003 I seem to have no way to use LDAP_SASL_BIND().  All LDAP functions work otherwise. Error is as follows:

Fatal error: Call to undefined function ldap_sasl_bind()

Manual says to compile with --with-ldap-sasl but that is not an option for Windows deployments.

Reproduce code:
---------------
if ($connect=ldap_connect($ldap_server)) {
	ldap_set_option($connect, LDAP_OPT_PROTOCOL_VERSION, 3);
	ldap_set_option($connect, LDAP_OPT_REFERRALS, 0);
	if ($bind=ldap_sasl_bind($connect, $auth_user, $password)) {
		ldap_close($connect);
		return true;
	}
	else {
		print ldap_error($connect) . '<br />';
	}
}//if connected to ldap
ldap_close($connect);
return false;


Expected result:
----------------
return true or return false

Actual result:
--------------
Fatal error: Call to undefined function ldap_sasl_bind()

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-10 22:18 UTC] jani@php.net
This is not a bug, just missing feature or rather: missing sasl support in the ldap libraries used to build win32 binaries.
 [2007-11-11 01:22 UTC] scott dot thomas at inin dot com
Can it be added in or perhaps a special build made so I can use this feature?  Do I have any other options besides moving to a non-Windows platform?
 [2010-05-12 11:11 UTC] bruno dot chalopin at laposte dot net
There is still no sasl support in ldap on Windows binaries (5.2.x or 5.3.x)
Why isn't it activate by default on Windows ? A lot of Active Directory Ldap server require a strong authentication like 'DIGEST-MD5' which is only provided by ldap_sasl_bind.
 [2010-05-12 12:42 UTC] pajoye@php.net
-Status: Open +Status: Assigned -Package: Feature/Change Request +Package: *General Issues -Assigned To: +Assigned To: pajoye
 [2010-05-12 12:42 UTC] pajoye@php.net
I don't think it can be done easily and it seems that even if it was supported, there are some issues with this auth method and AD (wrong enconding).

I will try to take a look at that for trunk, but don't hold your breath, that won't happen in 5.3.x for now.
 [2010-05-12 12:42 UTC] pajoye@php.net
-Package: *General Issues +Package: LDAP related
 [2010-05-17 22:09 UTC] pajoye@php.net
Automatic comment from SVN on behalf of pajoye
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=299434
Log: - #43233, sasl support for ldap on windows
 [2010-05-17 22:09 UTC] pajoye@php.net
-Status: Assigned +Status: Closed
 [2010-05-17 22:09 UTC] pajoye@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 [2010-05-17 22:22 UTC] pajoye@php.net
Automatic comment from SVN on behalf of pajoye
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=299435
Log: - #43233
 [2010-06-18 09:41 UTC] pajoye@php.net
5.3.3RC1 VC9 builds have SASL support now.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sun Apr 20 10:02:06 2014 UTC