php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43207 .htaccess settings missing (sometimes)
Submitted: 2007-11-06 18:25 UTC Modified: 2010-12-20 12:30 UTC
Votes:7
Avg. Score:4.6 ± 0.7
Reproduced:6 of 6 (100.0%)
Same Version:4 (66.7%)
Same OS:5 (83.3%)
From: phpmyforum at gmail dot com Assigned: jani
Status: Closed Package: Safe Mode/open_basedir
PHP Version: 5.2.5 OS: Linux
Private report: No CVE-ID:
 [2007-11-06 18:25 UTC] phpmyforum at gmail dot com
Description:
------------
Since I upgraded from php4 to PHP 5.2.5RC2 .htaccess php_* options getting ignored.
This happens for most, but not all requests.

The default (php.ini) option for register_globals is off.

My .htaccess file looks like this:
~~~~
php_flag register_globals on
~~~~

Now I downgraded to PHP 5.2.4 and it's working again.

Hint: this bug looks very similar to #28522.

PS: this may happen for other options

'./configure' '--prefix=/bbo/php' '--with-apxs2=/bbo/apachessl/bin/apxs' '--with-config-file-path=/bbo/etc/httpd' '--with-openssl=/bbo/usr' '--with-zlib' '--with-zlib-dir=/bbo/usr' '--with-bz2=/bbo/usr' '--enable-ftp' '--enable-exif' '--with-gd=/bbo/usr' '--enable-gd-native-ttf' '--with-jpeg-dir=/bbo/usr' '--with-png-dir=/bbo/usr' '--with-freetype-dir=/bbo/usr' '--with-mysql=/bbo/usr' '--with-mysqli=/bbo/usr/bin/mysql_config' '--with-pdo-mysql=/bbo/usr' '--with-iconv' '--with-iconv-dir=/bbo/usr' '--with-curl=/bbo/usr' '--with-curlwrappers' '--enable-soap' '--enable-sockets' '--enable-mbstring=all' '--enable-mbregex' '--with-xsl=/bbo/usr' '--with-libxml-dir=/bbo/usr' '--with-pspell=/bbo/usr' '--with-ldap=/bbo/usr' '--with-tidy=/bbo/usr' '--with-gettext=/bbo/usr' '--with-mcrypt=/bbo/usr' '--with-pcre-regex=/bbo/usr' '--enable-sigchild' '--enable-sysvshm' '--enable-sysvsem' '--enable-zip' '--disable-short-tags' '--with-pear=/bbo/php_includes' '--with-imap=/download/webserver/files/imap/' '--with-imap-ssl' '--without-kerberos'


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-11 18:49 UTC] jani@php.net
Try change the php_flag to php_value and use 0 or 1 as value.
 [2008-01-14 16:05 UTC] dan at eskhosting dot com
register_globals are switching On/Off randomise!
Values: 1/On/true, 0/Off/false; place: .htacess, httpd.conf - no difference.
Only global setting in php.ini are effective.
Other variables works good.

System: Red Hat Enterprise Linux ES release 4 (Nahant Update 6)
PHP: 5.2.5
'./configure' '--with-apxs=/usr/local/apache/bin/apxs' '--prefix=/usr/local' '--enable-bcmath' '--enable-calendar' '--with-curl' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-gettext' '--with-iconv' '--enable-mbstring' '--enable-mbregex' '--with-mcrypt' '--enable-magic-quotes' '--with-mysqli' '--with-mysql=/usr' '--with-openssl' '--enable-discard-path' '--with-pear' '--with-pgsql=/usr' '--enable-safe-mode' '--enable-sockets' '--with-ttf' '--with-freetype-dir=/usr' '--enable-gd-native-ttf' '--with-xmlrpc' '--with-xsl=/usr' '--enable-zip' '--with-zlib' '--with-bz2'
Apache: 1.3.37
 [2008-01-14 16:19 UTC] dan at eskhosting dot com
php_value/php_flag - no different too.
 [2008-02-25 12:12 UTC] phpmyforum at gmail dot com
> Try change the php_flag to php_value and use 0 or 1 as value.

Didn't help.


Today I could reproduce this behavior with PHP 5.2.5!
 [2008-02-25 14:16 UTC] manuel at mausz dot at
same as 43677. maybe some dev should finally apply one of my patches.
 [2008-03-14 12:00 UTC] jani@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows (zip):
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip

For Windows (installer):

  http://snaps.php.net/win32/php5.2-win32-installer-latest.msi

This should be fixed (patch from bug #43677 was applied! :)
 [2008-03-28 11:20 UTC] phpmyforum at gmail dot com
Thanks, seems to be fixed.
 [2010-12-20 12:30 UTC] jani@php.net
-Package: Tidy +Package: Safe Mode/open_basedir
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 01:01:56 2014 UTC