php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43192 Chunked HTML output difficult to use without TOC
Submitted: 2007-11-05 03:00 UTC Modified: 2007-11-05 20:45 UTC
From: ezyang@php.net Assigned: ezyang
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: Windows Vista
Private report: No CVE-ID:
 [2007-11-05 03:00 UTC] ezyang@php.net
Description:
------------
With the new TOC layout of PhD, the navigation is provided exclusively by the navigation on the right bar of the pages. While this makes good sense for phpweb, this makes chunkedhtml rather difficult to use, as it does not have a navigation sidebar, and the original TOC is now gone. 

chunkedhtml output is important because it allows those of us not interested in rolling the entire phpweb setup (not something trivial to do) to easily access the manual.

Doing this in a universal manner may be difficult. I think that we should bring back the old behavior of index.html having a full table of contents, but this may require more discussion.

Reproduce code:
---------------
Build PhD using chunkedhtml

Expected result:
----------------
Resulting html/index.html page has full table of contents, or navigation bars for pages are generated

Actual result:
--------------
Chunked HTML output is only traversable through Next and Back buttons, as well as intermediate TOCs.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-05 08:22 UTC] rquadling@php.net
I think this is going to be the basis for those systems (like the MS Windows CHM file) which do not need a pre-generated TOC as the app has that capability built-in.



 [2007-11-05 20:45 UTC] bjori@php.net
This bug has been fixed in CVS. Since the websites are not directly
updated from the CVS server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 24 19:01:53 2014 UTC