php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43191 build.php fails to included necessary theme dependencies
Submitted: 2007-11-05 02:51 UTC Modified: 2007-11-05 20:04 UTC
From: ezyang@php.net Assigned:
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: Windows Vista
Private report: No CVE-ID:
 [2007-11-05 02:51 UTC] ezyang@php.net
Description:
------------
When attempting to run builds of just chunkedhtml, etc, PhD cannot find the necessary parent classes. This can be fixed by either including all of the requisite classes from build.php, having the themes perform their necessary inclusions (be careful about register globals injections), or setting up some sort of autoload scheme.

Reproduce code:
---------------
$ php build.php --theme chunkedhtml --docbook /path/to/phpdoc/.manual.xml

Expected result:
----------------
Build proceeds as normal

Actual result:
--------------
Fatal error: Class 'phpweb' not found in C:\Users\Edward\Webs\phd\themes\php\chu
nkedhtml.php on line 2

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-05 20:04 UTC] bjori@php.net
This bug has been fixed in CVS. Since the websites are not directly
updated from the CVS server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sun Apr 20 08:02:33 2014 UTC