php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43123 Memory Access Violation when closing Web Server
Submitted: 2007-10-29 04:56 UTC Modified: 2007-10-29 14:29 UTC
From: gabri dot ns at googlemail dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 5.2.4 OS: Windows 98/XP
Private report: No CVE-ID: None
 [2007-10-29 04:56 UTC] gabri dot ns at googlemail dot com
Description:
------------
I think it is not an IIS problem (I using AbyssWeb Server),
but ISAPI related, because this error doesn't exist when using CGI as the interface.

This error occur when I try to shutdown the server.
Everything normal before shutdown proses (in the surface,i don't have a debugger).
The AbyssWS's crashrep.txt report the error related to php5isapi.dll and libMySQL.dll

Don't ask me to change the interface to CGI.
I have tried it, but since I using low memory computer
it can't be done.

Thank's before.

Reproduce code:
---------------
Step by step error reproduce procedure

Set php.ini to load MySQL module
Start the AbyssWS
--> If we shutdown the server now, no error occur
Open the web http://localhost/phpinfo.php
Shutdown the server

Expected result:
----------------
no error occur

Actual result:
--------------
Error Box with Memory Access Violation error

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-10-29 14:29 UTC] jani@php.net
We are aware of PHP's problems with stability under IIS and are working 
to rectify the problem. Unfortunatly your bug report does not contain any
extra useful information and we already have enough bug reports open about
this issue. If you can provide more detailed information such as a 
reproducable crash or a backtrace please do so and reopen this bug. 
Otherwise please keep trying new releases as we are working to resolve 
the problems on this platform
 
Thanks for your interest in PHP.

Use FastCGI, it's lighter plus works correctly.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jul 23 17:01:30 2024 UTC