|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43002 Unwanted timeout at end of script
Submitted: 2007-10-17 03:05 UTC Modified: 2007-10-18 15:22 UTC
From: anrdaemon at freemail dot ru Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.2.4 OS: Win2000
Private report: No CVE-ID:
 [2007-10-17 03:05 UTC] anrdaemon at freemail dot ru
PHP stuck for about 5 seconds after end of script while php_mysql extension loaded with bundled libmysql.dll.
CGI executable reporting
"Error in my_thread_global_end(): 1 threads didn't exit"
(It was 1 or 2 threads from time to time)

Reproduce code:
Just run 
<?php phpinfo(); ?>
script from console.

Expected result:
Expecting no delay after end of script output.

Actual result:
Got about 5 sec delay after end of script output (PHP-CLI/PHP-WIN)
In addition to that delay, string 
"Error in my_thread_global_end(): 1 threads didn't exit"
being written to STDERR (PHP-CGI)

Actually, problem disappears when using libmysql.dll from Connector/PHP or from installed MySQL server.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2007-10-17 08:59 UTC]
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

See #42345
 [2007-10-18 15:22 UTC]
The one from #42345 is about mssql and not mYsql. But there is already #41350 or #42714.
PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Thu Nov 26 19:01:33 2015 UTC