php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4283 include_path error with PHP4 RC1 Roxen module
Submitted: 2000-04-30 05:29 UTC Modified: 2001-04-28 15:31 UTC
From: andreas at waikato dot ac dot nz Assigned:
Status: Closed Package: Other web server
PHP Version: 4.0rc1 OS: SuSE Linux 6.3
Private report: No CVE-ID: None
 [2000-04-30 05:29 UTC] andreas at waikato dot ac dot nz
The PHP4 RC1 Roxen module has obviously a problem with the include_path variable. In my pages I usually type something like include("file.txt"); and it used to work with PHP3 in both cases, Apache module or CGI. Now when I installed Roxen 2.0.46 and compiled PHP4 as a Roxen module it cannot determine the include_path, not even after I experimentally copied the php3.ini to php.ini in order to use this file with PHP4 to check the issue.
Problem as I see it is, that I might be well able to adjust my own scripts but as soon as I grab somebody elses it might not work --> phpMyAdmin.
The include path variable in php(3).ini is empty because I want to use it for many domains and the path line would just be endless. However, it used to work this way with PHP3.

Cheers,
Andreas

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-10 16:25 UTC] jimw@php.net
fix version.
 [2001-03-29 11:47 UTC] sniper@php.net
Does this happen with PHP 4.0.4pl1?

--Jani

 [2001-04-28 15:31 UTC] derick@php.net
No feedback. If this problem persists with PHP 4.0.5 which
will be released next week, please reopen this report.

Derick
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 14:01:26 2020 UTC