php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42822 Unable to load dynamic library '../mysql.ini'
Submitted: 2007-10-02 00:06 UTC Modified: 2007-10-02 09:24 UTC
From: chriswhite31 at hotmail dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 5.2.4 OS: Redhat Linux Fedora 5
Private report: No CVE-ID: None
 [2007-10-02 00:06 UTC] chriswhite31 at hotmail dot com
Description:
------------
Hey, i am trying to run a Scheduled Cron Job using "php --dump (link) > /dev/null" and i am recieving this error;

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/mysql.ini' - /usr/lib/php/modules/mysql.ini: file too short in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/php_mysql.dll' - /usr/lib/php/modules/php_mysql.dll: invalid ELF header in Unknown on line 0
PHP Warning:  Module 'mysql' already loaded in Unknown on line 0
Could not open input file: http://www.theshadowofevil.com/crons/backupDB.php?StartBackup=normal

PHPInfo():http://www.theshadowofevil.com/phpinfo.php
PHP Version:5.1.6
System hostname:theshadowofevil.com
Operating system:Redhat Linux Fedora 5
Webmin version:1.370

Reproduce code:
---------------
Contents of mysql.ini
; Enable mysql extension module
extension=mysql.so

Contents of php_mysql.dll
MZ?

Contents of mysql.so
ELF

Expected result:
----------------
Backup mysql database.
Another script should update mysql database.

Actual result:
--------------
Produces error from the command line.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-10-02 00:10 UTC] chriswhite31 at hotmail dot com
Ive made the directory unwriteable because i forgot to remove the exposed link / database.
 [2007-10-02 09:24 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Feb 23 08:01:29 2024 UTC