php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42792 bitwise bug
Submitted: 2007-09-28 19:11 UTC Modified: 2007-09-29 09:41 UTC
From: yy at jjxx dot com Assigned:
Status: Not a bug Package: Math related
PHP Version: 5.2.4 OS: FreeBSD 6.2
Private report: No CVE-ID: None
 [2007-09-28 19:11 UTC] yy at jjxx dot com
Description:
------------
./configure --with-apxs=/usr/local/apache/sbin/apxs --disable-debug --with-xml --with-gd --with-iconv --prefix=/usr/local/php --with-jpeg-dir --with-png-dir --with-ttf --with-freetype-dir --enable-gd-native-ttf --disable-posix --enable-mbstring --with-pgsql --with-config-file-path=/usr/local/php/lib --with-curl --enable-bcmath


Reproduce code:
---------------
echo( -4738698913 ^ 43814 );
echo "\n";
echo decbin(-4738698913);

Expected result:
----------------
-443704711
11100101100011010011000101011111

Actual result:
--------------
-2147439834
10000000000000000000000000000000

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-29 09:41 UTC] scottmac@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

The integer type in PHP is a 32-bit signed integer, you can use the PHP_INT_MAX constant to check the size available on your system.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 17 21:01:24 2020 UTC