php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42747 option --enable-dio not recognized
Submitted: 2007-09-24 16:18 UTC Modified: 2007-09-24 17:17 UTC
From: richard dot cubek at web dot de Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.2.4 OS: Suse Linux 10.2
Private report: No CVE-ID: None
 [2007-09-24 16:18 UTC] richard dot cubek at web dot de
Description:
------------
As described on http://www.php.net/manual/en/ref.dio.php i added --enable-dio as option, my complete configuration command is:

./configure --with-apxs2=/usr/sbin/apxs2-prefork --with-mysql --with-gd --enable-gd-native-ttf --with-zlib-dir=/usr/lib --with-png-dir=/usr/lib --with-jpeg-dir=/usr/lib --with-freetype-dir=/usr/lib --with-bz2 --enable-dio 

Works fine, but at the end of the output, I get:
---
Thank you for using PHP.

Notice: Following unknown configure options were used:

--enable-dio

Check './configure --help' for available options

---

So, option --enable-dio is not recognized. With 

./configure --help | grep dio

i also get no result. After 'make install', calling the function dio_open() then calls an fatal error (unknown function...).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-24 17:17 UTC] pajoye@php.net
It is not bundled anymore. See http://pecl.php.net/dio to fetch the CVS  version (being unmaintained, there is no release in pecl). Not a bug > bogus.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Aug 16 10:05:45 2022 UTC