php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42732 EXAMPLE 2251 TYPO (smptget)
Submitted: 2007-09-22 09:00 UTC Modified: 2007-10-02 10:32 UTC
From: brunoseys at telenet dot be Assigned:
Status: Not a bug Package: SNMP related
PHP Version: 6CVS-2007-09-22 (snap) OS: irrelevant
Private report: No CVE-ID: None
 [2007-09-22 09:00 UTC] brunoseys at telenet dot be
Description:
------------
According the SNMPv2-MIB DEFINITIONS the right syntax should be  "system.sysContact.0" and NOT "system.SysContact.0" as used is example 2251. 

SNMPv2-MIB DEFINITIONS 
...
sysContact OBJECT-TYPE
    SYNTAX      DisplayString (SIZE (0..255))
    MAX-ACCESS  read-write
    STATUS      current
    DESCRIPTION
            "The textual identification of the contact person for this
            managed node, together with information on how to contact
            this person.  If no contact information is known, the value
            is the zero-length string."
    ::= { system 4 }

Reproduce code:
---------------
//example 2251. Using snmpget()
<?php
$syscontact = snmpget("127.0.0.1", "public", "system.SysContact.0");
?>


Expected result:
----------------
IRRELEVANT (system depending)

Actual result:
--------------
Warning: snmpget() [function.snmpget]: Invalid object identifier: system.SysContact.0 inC:\apachefriends\xampp\htdocs\edu\snmp_test.php on line 36


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-10-02 10:32 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 22 15:01:24 2020 UTC