php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42714 Error in my_thread_global_end(): 3 threads didn't exit
Submitted: 2007-09-19 17:33 UTC Modified: 2010-08-18 12:38 UTC
Votes:18
Avg. Score:4.3 ± 1.3
Reproduced:15 of 18 (83.3%)
Same Version:5 (33.3%)
Same OS:6 (40.0%)
From: rafael dot figueiredo at prowebs dot com dot br Assigned: scottmac (profile)
Status: Duplicate Package: MySQL related
PHP Version: 5.2.4 OS: WINDOWS 2003 SP1
Private report: No CVE-ID: None
 [2007-09-19 17:33 UTC] rafael dot figueiredo at prowebs dot com dot br
Description:
------------
Always when a load a page .php I receive this message "Error in my_thread_global_end(): 3 threads didn't exit". When all my page contents show the browser stay "receiving" for more 5 seconds and then show these message.
This error occurs even a put a simple <?php phpinfo(); ?> or <?php ?>

How could I resolve this?

My system:
- Win 2003 SP1
- php-5.2.4-win32-installer.msi
- mysql-essential-5.0.45-win32.msi

Thanks,
Rafael.

Reproduce code:
---------------
<?='HELLO!'?>

Expected result:
----------------
HELLO!

Actual result:
--------------
HELLO!Error in my_thread_global_end(): 3 threads didn't exit

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-20 13:28 UTC] jani@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows (zip):
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip

For Windows (installer):

  http://snaps.php.net/win32/php5.2-win32-installer-latest.msi

Should be fixed already.
 [2007-10-18 15:34 UTC] joerg@php.net
Problem exists also in the latest snapshots
C:\>php -v
PHP 5.2.5-dev (cli) (built: Oct 18 2007 08:04:14)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
Error in my_thread_global_end(): 1 threads didn't exit

There is no code example needed because a simple php -v or -m shows the error. To avoid problem with existing libmysql.dll the mysqld was deinstalled befor testing.
 [2007-10-18 16:10 UTC] scottmac@php.net
What MySQL extensions do you have installed? MySQL, MySQLi and pdo_mysql?

What version of libmysql does the phpinfo page show?
 [2007-10-18 16:53 UTC] joerg@php.net
Its only ext/mysql and no pdo used.

c:\php -i 
[..]
mysql

MySQL Support => enabled
Active Persistent Links => 0
Active Links => 0
Client API version => 5.0.45

[..]
If you did not receive a copy of the PHP license, or have any
questions about PHP licensing, please contact license@php.net.
Error in my_thread_global_end(): 1 threads didn't exit


As a workaround the libmysql.dll from the old 5.2.1 works. But this was already mentioned in earlier posts.

I have verified that there is no other libmysql.dll on the system. A test with a renamed file give the "canot load ...." error because no libmysql.dll was found.


 [2007-10-18 16:59 UTC] cranderson at att dot net
I can confirm this on Win2000 using MySQL libmysql (5.0.45) and with the DLL from the latest snapshot.  Oddly, it works with the 5.2.3 php_mysql/i.dlls.  Also checked to see if libmysql.dll existed elsewhere (MySQL GUI Tools) and fixed that.  To verify that the correct paths and DLLs are being read, I used 'Process Explorer' from Microsoft (formerly SysInternals).

I can't get the same result on XP Pro SP2 nor Win2003 Server.  I don't have the php_mysqli.dll source, but did sniff it with a plug-in.  Some additions (e.g. mysql_thread_init()) might have something to do with it??
 [2007-10-21 16:07 UTC] dominic dot ryan at it-hq dot org
I am also getting this error on a fresh Windows build simply by using the <?php phpinfo(); ?> script. I can also confirm that using libmysql.dll from PHP 5.2.1 appears to fix the issue. My server details are; 

Windows 2003 R2 SP2 32bit 
IIS 6
PHP 5.2.4 (CGI)
MySQL Server 5.0.45
 [2007-10-22 11:06 UTC] andrey@php.net
Please try to use libmysql from 5.2.1, then problem should be solved. 5.2.4 is broken and there is a fix in 5.2.5-dev, RC1 of 5.2.5 is already out, thus a fixed version is pending. The fixed version will include libmysql 5.0.45 which will work together with PHP5. Due to a bug in PHP 5.2.4 libmysql 5.0.45 doesn't work, and gives that error.
 [2007-10-30 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2007-11-23 22:31 UTC] starascendant at hotmail dot com
I am also experiencing this error any time any of the mysql extensions are uncommented.

PHP 5.2.5 (cli) (built: Nov  8 2007 23:18:51)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
 [2007-11-23 22:43 UTC] starascendant at hotmail dot com
I tried to post the complete PHP info dump but the wack job spam filter won't let me.
 [2008-06-30 18:02 UTC] YPY_Design at Yuhoo dot co dot uk
Not resolved(Remote host)!
 [2010-08-18 12:38 UTC] andrey@php.net
-Status: No Feedback +Status: Duplicate
 [2010-08-18 12:38 UTC] andrey@php.net
It's a dupe, I don't have the exact bug number handy.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 20 16:01:23 2020 UTC