php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #42713 Undocumented behavior when strftime() $format param is >= 1024 characters
Submitted: 2007-09-19 14:35 UTC Modified: 2007-11-21 15:49 UTC
From: josh dot helzer at gmail dot com Assigned:
Status: Closed Package: Documentation problem
PHP Version: 5.2.4 OS: Irrelevant
Private report: No CVE-ID: None
 [2007-09-19 14:35 UTC] josh dot helzer at gmail dot com
Description:
------------
If strlen($format) >= 1024, then the output of strftime($format, $date) is the empty string.

I'd at least like to see a note of this appear in strftime()'s documentation.exactly


Reproduce code:
---------------
strftime(str_repeat('a', 1024), time())

Expected result:
----------------
str_repeat('a', 1024)

Actual result:
--------------
''

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-21 15:49 UTC] vrana@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

"Maximum length of this parameter is 1023 characters."
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Apr 17 15:01:24 2021 UTC