php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42514 Russian translation is not correct in docs about mysql_fetch_array()
Submitted: 2007-09-01 19:46 UTC Modified: 2007-09-04 14:42 UTC
From: lio85 at mail dot ru Assigned:
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS: No matter
Private report: No CVE-ID: None
 [2007-09-01 19:46 UTC] lio85 at mail dot ru
Description:
------------
Russian translation in documentation about mysql_fetch_array() function is not correct. More, there is an error in world "медленне" (must be "медленнее").
quote (English version)
"Performance: An important thing to note is that using mysql_fetch_array() is not significantly slower than using mysql_fetch_row(), while it provides a significant added value."
In Russian version 
"Важно заметить, что mysql_fetch_array() работает НЕ медленне, чем mysql_fetch_row(), в то время, как предоставляет более удобный доступ к данным."
That says "mysql_fetch_array works NOT slower than mysql_fetch_row()"

Reproduce code:
---------------
just look at documentation. all there

Expected result:
----------------
Важно заметить, что mysql_fetch_array() работает не значительно медленнее, чем mysql_fetch_row(), в то время, как предоставляет более удобный доступ к данным.

Actual result:
--------------
Важно заметить, что mysql_fetch_array() работает НЕ медленне, чем mysql_fetch_row(), в то время, как предоставляет более удобный доступ к данным.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-03 19:53 UTC] tony2001@php.net
IMO "not significantly slower" is almost similar to "not slower".
Feel free to provide better translation though.
Thanks for noticing the typo btw.

 [2007-09-04 14:34 UTC] lio85 at mail dot ru
"Not slower" means faster or similar, but in practice it slower for about 20%. "Not significantly slower" - means not so slower to keep it in mind. IMHO just because IT IS SLOWER, there must not be "not slower" in documentation, how it is in English docs. So, it is your decision what to write in documentation... "Not slower" confused me.
 [2007-09-04 14:42 UTC] tony2001@php.net
I repeat: feel free to provide better translation.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jul 10 03:01:26 2020 UTC