php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42417 Buildconf warns about wrong version of autoconf
Submitted: 2007-08-24 18:24 UTC Modified: 2007-08-24 20:29 UTC
From: b dot mosher at podshow dot com Assigned:
Status: Not a bug Package: Compile Warning
PHP Version: 5.2.3 OS: CentOS 4
Private report: No CVE-ID: None
 [2007-08-24 18:24 UTC] b dot mosher at podshow dot com
Description:
------------
When running buildconf on the 5.2.3 release sources, it complains that I'm not using autoconf 2.13. I am using 2.59 which shouldn't trigger the warning from what I can gather in the OK message right before the warning. The warning advises downgrading autoconf severely. If autoconf truly is using buggy cache code in 2.59, please advise. However this warning has been generated since at least PHP 4.3x (http://bugs.php.net/bug.php?id=34328 and http://bugs.php.net/bug.php?id=33922&edit=2 which don't hve satisfactory solutions for the spurious warning)

Reproduce code:
---------------
[b.mosher@foo:~/php-5.2.3]$ ./buildconf --force
Forcing buildconf
using default Zend directory
buildconf: checking installation...
buildconf: autoconf version 2.59 (ok)
buildconf: Your version of autoconf likely contains buggy cache code.
           Running cvsclean for you.
           To avoid this, install autoconf-2.13.
[b.mosher@foo:~/php-5.2.3]

Expected result:
----------------
"buildconf: autoconf version 2.59 (ok)" should be the last message.

Actual result:
--------------
see reproduce section

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-08-24 20:22 UTC] johannes@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Autoconf 2.59 works for most stuff, but without that cvs clean call things might brake, version 2.13 works better...
 [2007-08-24 20:29 UTC] b dot mosher at podshow dot com
I don't want to sound rude (I really appreciate the response), but shouldn't the build process be updated rather than recommend a 6 year old version of autoconf? Is it planned for >2.13 support someday or did the way autoconf works dramatically change? Just curious :)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 06:01:23 2020 UTC