php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42366 xmlwriter fails "make test"
Submitted: 2007-08-21 20:39 UTC Modified: 2007-08-23 14:04 UTC
From: dannie dot stanley at gmail dot com Assigned:
Status: Not a bug Package: XML Writer
PHP Version: 5.2.3 OS: RHEL3
Private report: No CVE-ID: None
 [2007-08-21 20:39 UTC] dannie dot stanley at gmail dot com
Description:
------------
Two of the tests for xmlwriter fail.  The expected output seems to be incorrect.  The expected output files 

   * ext/xmlwriter/tests/OO_007.exp
   * ext/xmlwriter/tests/007.exp

Have the xmlns:ns1 attribute repeated 3 times.  The output provided from the test only has that attribute listed one time, which seems to be valid.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-08-21 20:47 UTC] dannie dot stanley at gmail dot com
Example diff of file with the problem:


--- /tmp/ootest.txt     2007-08-21 16:17:11.000000000 -0400
+++ ext/xmlwriter/tests/OO_007.exp      2007-08-21 16:38:59.000000000 -0400
@@ -1,6 +1,6 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <root>
-   <ns1:child1 ns1:att1="a&amp;b" att2="double&quot; single'" ns1:att2="&lt;&gt;&quot;'&amp;" xmlns:ns1="urn:ns1">
+   <ns1:child1 xmlns:ns1="urn:ns1" ns1:att1="a&amp;b" xmlns:ns1="urn:ns1" att2="double&quot; single'" ns1:att2="&lt;&gt;&quot;'&amp;" xmlns:ns1="urn:ns1">
       <chars>special characters: &lt;&gt;&quot;'&amp;</chars>
    </ns1:child1>
-</root>
+</root>
\ No newline at end of file
 [2007-08-22 08:06 UTC] jani@php.net
What is the libxml version you have linked PHP with?
 [2007-08-22 10:19 UTC] dannie dot stanley at gmail dot com
I have compiled against:

   libxml2-2.6.29
   libxslt-1.1.21

I believe both of those are the latest.
 [2007-08-22 11:55 UTC] rrichards@php.net
That test has changed since the 5.2.3 release to due bug fixes in libxml2
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Jan 23 07:01:25 2019 UTC