php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42249 maximum of 200 fields in $_POST/$_REQUEST
Submitted: 2007-08-08 16:02 UTC Modified: 2007-08-08 16:33 UTC
From: tp at tpsoftware dot nl Assigned:
Status: Not a bug Package: *Web Server problem
PHP Version: 5.2.4RC1 OS: OpenSuSE10
Private report: No CVE-ID: None
 [2007-08-08 16:02 UTC] tp at tpsoftware dot nl
Description:
------------
After updating from version 5.1.2 to 5.2.3 no more than 200 fields are being recognized in the $_REQUEST or $_POST array. 
Just sending 250 vars in a form results in just 200 variables.



Reproduce code:
---------------
<?
if ($_POST['upload']==1)
{
	echo "Count: " . count($_POST);
	exit();
} else {
	$inputvars = "";
	for ($i=0;$i<250;$i++)
	{
	$inputvars .= "<input type='hidden' name='var".$i."' value='".$i."'>";
	}
?>
<html>
<body>
<form method='post' action='phpinfo.php'>
<input type='hidden' name='upload' value='1'>
<?= $inputvars?>
<input type='submit' name='button' value='go'>
</form>
</body>
</html>
<?
}
?>

Expected result:
----------------
Count: 252

Actual result:
--------------
Count: 200

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-08-08 16:33 UTC] johannes@php.net
This looks like an limitation from the Suhosin patch, please make sure Suhosin is disabled when reporting PHP bugs. See the Suhosin documentaiton on http://suhosin.org/ for more.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 20 21:03:37 2021 UTC