php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4211 Apahce fails to load libphp4.so
Submitted: 2000-04-20 17:51 UTC Modified: 2002-09-30 19:49 UTC
From: tim at tjkern dot com Assigned:
Status: Not a bug Package: Oracle related
PHP Version: 3.0.16 OS: RedHat 6.2 (2.2.14)
Private report: No CVE-ID: None
 [2000-04-20 17:51 UTC] tim at tjkern dot com
Hardware:
	DELL XPST PIII 500MHz
	256M RAM
Software:
	Orcale 8.1.5.2
	RedHat 6.2
	Apache 1.3.12
	PHP 4.0 RC1
Env:
	$ORACLE_HOME, $ORACLE_SID, standard paths for root
	bash shell

apache command line:
	./configure --with-prefix=/my/path \
		  --enable-modules=all \
		  --enable-shared=max \
		  --enable-module=rewrite \
		  --enable-shared=rewrite
...no errors...httpd starts normally...

php command line:
	./configure --with-oracle --with-apxs=/path/to --with-track-vars
...compiles/installs without error...

After installation, I try to restart apache and get the error:
Cannot load /path/libphp4.so into server: libclntsh.so.8.0 cannot open shared library or object: No such file or directory

...it looks like it could be a permission problem...I've seen the problem before with Oracle installations...it occurs after an Oracle install when trying to run svrmgrl or other apps...the cure is to run $ORACLE_HOME/install/utl/linux.sh...I tried to apply that fix, but it hosed my Oracle installation...anyway, if I can help you track this one down, just send me a note...

NOTE: php 3.16 works fine with the Oracle installation

Tim Kern

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-30 19:49 UTC] hholzgra@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 02:01:28 2024 UTC