php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42081 SoapClient cannot connect to server
Submitted: 2007-07-23 18:26 UTC Modified: 2007-08-01 09:47 UTC
Votes:2
Avg. Score:1.0 ± 0.0
Reproduced:0 of 2 (0.0%)
From: gpf at hot dot ee Assigned: dmitry (profile)
Status: Not a bug Package: SOAP related
PHP Version: 5.2.3 OS: Windows Vista
Private report: No CVE-ID: None
 [2007-07-23 18:26 UTC] gpf at hot dot ee
Description:
------------
I got fopen with URL-s work on Windows Vista. Changing host file makes fopen work with URL-s. Just comment out the line

:: 1

But I found another weird thing. Although fopen works now SoapClient still gets the error A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. Same error appears also to error.log.

Reproduce code:
---------------
$client = new SoapClient('http://127.0.0.1/wcftest/MathService.svc?wsdl');
var_dump($client->__getFunctions());


Expected result:
----------------
It should dump out all methods found from web service called MathService.

Actual result:
--------------
The following lines in error.log:

[Mon Jul 23 20:20:32 2007] [error] [client 192.168.1.103] PHP Warning:  SoapClient::SoapClient(http://127.0.0.1/wcftest/MathService.svc?xsd=xsd0) [<a href='function.SoapClient-SoapClient'>function.SoapClient-SoapClient</a>]: failed to open stream: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.\r\n in C:\\www\\htdocs\\wcf.php on line 6, referer: http://127.0.0.1:8080/
[Mon Jul 23 20:20:32 2007] [error] [client 192.168.1.103] PHP Warning:  SoapClient::SoapClient() [<a href='function.SoapClient-SoapClient'>function.SoapClient-SoapClient</a>]: I/O warning : failed to load external entity &quot;http://127.0.0.1/wcftest/MathService.svc?xsd=xsd0&quot; in C:\\www\\htdocs\\wcf.php on line 6, referer: http://127.0.0.1:8080/
[Mon Jul 23 20:20:32 2007] [error] [client 192.168.1.103] PHP Fatal error:  SOAP-ERROR: Parsing Schema: can't import schema from 'http://127.0.0.1/wcftest/MathService.svc?xsd=xsd0' in C:\\www\\htdocs\\wcf.php on line 6, referer: http://127.0.0.1:8080/
[Mon Jul 23 20:20:32 2007] [error] [client 192.168.1.103] PHP Fatal error:  Maximum execution time of 30 seconds exceeded in C:\\www\\htdocs\\wcf.php on line 11, referer: http://127.0.0.1:8080/


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-07-25 19:40 UTC] will dot fitch at gmail dot com
I have tried this on Vista Ultimate running PHP 5.2.3 and it works fine.  

Can you supply your WSDL?  It sounds like either your local machine (specific to your computer) isn't responding, or your soap:address is looking elsewhere.
 [2007-08-01 09:47 UTC] dmitry@php.net
This is not an ext/soap bug.
Probably this is a local configuration problem.

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Feb 03 13:05:52 2023 UTC