php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42045 Installer: Add Extra component (LDAP/OpenSSL) leaves out some files
Submitted: 2007-07-19 09:47 UTC Modified: 2008-08-22 18:14 UTC
From: mamama at kirakira dot xs4all dot nl Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.3 OS: Windows Server 2003
Private report: No CVE-ID: None
 [2007-07-19 09:47 UTC] mamama at kirakira dot xs4all dot nl
Description:
------------
1) During install (Windows installer) don't add LDAP and OpenSSL as Extra component.
2) Run the installer again and now add these components.

There should be 2 DLLs added in the PHP install directory (libeay32.dll and ssleay32.dll), but only one is there.

3) Run the installer to REPAIR the installation. This will add the missing file, but also "messes up" the PHP.ini file.

Reproduce code:
---------------
[ not php code related ]

Expected result:
----------------
-

Actual result:
--------------
-

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-07-19 11:47 UTC] jmertic@php.net
I cannot reproduce this bug; I am seeing the expected behaviour.

What other extensions are you installing at the same time? Perhaps one of them has a conflict.
 [2007-07-19 12:24 UTC] mamama at kirakira dot xs4all dot nl
First install:
  Program: CLI Executable
  Extensions: Only MySQL
  Web server: IIS CGI
  Exras: (all)

Second install:
  Extensions: added LDAP and OpenSSL
  (result: missing file)

Repair install: missing file was added, but php.ini changed.
 [2007-07-19 18:24 UTC] jmertic@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

There was an issue of a duplicate GUID for two of the components you were using. I went thru and found a couple other duplicates as well. All are corrected in CVS now.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 19:03:40 2021 UTC