php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #41960 HTML Help file (29 Jul 2007) version of PHP manual has missing information.
Submitted: 2007-07-11 06:36 UTC Modified: 2008-07-21 08:45 UTC
Votes:4
Avg. Score:4.8 ± 0.4
Reproduced:4 of 4 (100.0%)
Same Version:4 (100.0%)
Same OS:4 (100.0%)
From: eugenew at starhub dot net dot sg Assigned:
Status: Closed Package: Documentation problem
PHP Version: Irrelevant OS: Microsoft Windows XP SP2
Private report: No CVE-ID: None
 [2007-07-11 06:36 UTC] eugenew at starhub dot net dot sg
Description:
------------
I downloaded the English CHM version of the PHP manual (dated 7 July 2007) from both Singapore mirrors. In each case, the "Table of Contents" is not shown and is replaced by a "This program cannot display the webpage" message. The same applies for the "Zend API", "PHP API", "FAQ" and "Appendixes" sections. The previous release of the HTML help file version (dated 20 June 2007) did not have such a problem, so it appears to be a bug in generating the documentation. I note that the previous release had a filesize of around 7938 KB, but this new release has a filesize of around 2620 KB.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-07-27 11:22 UTC] nlopess@php.net
the html_xsl target works, so the new chm files should be fine.
Please wait until the files are rebuilt.
 [2007-07-31 17:51 UTC] eugenew at starhub dot net dot sg
Thanks for the bug fix. However, I downloaded the new version the new English CHM version of the PHP manual dated 29 Jul 2007. The "This program cannot display the webpage" error message still appears for "Zend API", "PHP API", the "Extending PHP 3" section under "Appendixes", and the "Function Index" page under the "Function Index" section under "Appendixes".
 [2007-08-16 16:09 UTC] info at tclogic dot nl
for the dutch manual it works neither,
please fixit. it is now older then 2 month

Bert-Pieter Oelen
 [2008-06-23 09:36 UTC] nlopess@php.net
not for me anymore. I'll leave this for the GSoC student.
 [2008-07-21 08:45 UTC] loudi@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

no more missing pages with the new building system, please wait until this version is downloadable in php.net website
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Dec 02 01:01:24 2020 UTC