php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41647 php and sql server 2000
Submitted: 2007-06-11 09:40 UTC Modified: 2007-06-11 14:49 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: giannisptr at yahoo dot gr Assigned:
Status: Not a bug Package: *Unicode Issues
PHP Version: 5.2.3 OS: Win XP
Private report: No CVE-ID: None
 [2007-06-11 09:40 UTC] giannisptr at yahoo dot gr
Description:
------------
I implement a web site that invokes a web service (using nusoap.php).
The web service queries a table from an sql server 2000 database and returns a string with the records returned.
The problem is that althou english characters appear correctly into the string, the greek characters are all replayed by '?'.
When used iconv and mb_convert_encoding neither greek nor english characters apper correctly. 
Is the any solution to this problem???

Reproduce code:
---------------
//call web service
$retstr= $client->call('GetRecords',$param);

//returned string
print $retstr;

//using iconv
print iconv("UCS-2","UTF-8",$retstr);

//using mb_convert_encoding
print mb_convert_encoding($retstr,"UTF-8","UCS-2");


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-06-11 14:49 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Feb 20 09:01:25 2020 UTC