|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41587 After install, I can't start Apache 2
Submitted: 2007-06-04 12:45 UTC Modified: 2007-06-14 10:22 UTC
From: webtech at get-telecom dot fr Assigned:
Status: Closed Package: Apache2 related
PHP Version: 5.2.3 OS: Solaris 10
Private report: No CVE-ID: None
 [2007-06-04 12:45 UTC] webtech at get-telecom dot fr
I tried the latest version 5.2.3 on Solaris 10(AMD64) as a module on Apache 2.0.59.
After the compilation, and installation, I've tried to restart Apache and I have this error message :

Syntax error on line 232 of /www/apache-2.0.59/conf/httpd.conf:
Cannot load /www/apache2/modules/ into server: httpd: fatal: /usr/lib/ wrong ELF class: ELFCLASS32

For info, everything's ok with PHP 5.2.2.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2007-06-04 13:00 UTC]
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

 [2007-06-13 14:44 UTC] webtech at get-telecom dot fr
I think you're right but why is it ok with PHP 5.2.2 ?
 [2007-06-14 10:22 UTC] webtech at get-telecom dot fr
I've found a solution : 

Add these two lines :
    export LD_PRELOAD
in [APACHE_HOME]/bin/envvars

Hope it'll help.
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Mon Oct 02 18:01:24 2023 UTC