php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #41502 getColumnMeta() table name support for pdo_sqlite
Submitted: 2007-05-25 19:12 UTC Modified: 2018-10-06 11:47 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: Antti dot Andreimann at mail dot ee Assigned: cmb (profile)
Status: Closed Package: PDO SQLite
PHP Version: 5CVS-2007-05-25 (snap) OS: all
Private report: No CVE-ID: None
 [2007-05-25 19:12 UTC] Antti dot Andreimann at mail dot ee
Description:
------------
During the processing of FR #41416 PDO->getColumnMeta was enhanced so, that it will return table names for mysql result columns.
Since this is a useful feature for other DBMS's as well I have created
a patch that will implement this feature in pdo_sqlite.

http://www.linux.ee/~anttix/php-pdo_sqlite-tablenames.patch

Please consider committing.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-12-20 14:23 UTC] jani@php.net
-Package: Feature/Change Request +Package: SQLite related
 [2016-06-27 16:20 UTC] cmb@php.net
-Package: SQLite related +Package: PDO SQLite
 [2017-10-20 18:38 UTC] kalle@php.net
-Status: Assigned +Status: Open -Assigned To: iliaa +Assigned To:
 [2017-10-20 18:38 UTC] kalle@php.net
Unassigning as Ilia is not currently active
 [2018-09-21 21:28 UTC] cmb@php.net
-Status: Open +Status: Verified -Assigned To: +Assigned To: cmb
 [2018-09-21 21:28 UTC] cmb@php.net
This issue has already been fixed via commit efaba65[1], but since
the fix relies on a compile time macro of SQLite[2], it can't work
for system libsqlite3 (i.e. only bundled libsqlite3 is supported).

[1] <http://git.php.net/?p=php-src.git;a=commit;h=efaba65cf5aa5e6469bd6c53637b950934dccd44>
[2] <https://github.com/php/php-src/blob/php-7.3.0RC1/ext/pdo_sqlite/sqlite_statement.c#L334-L339>
 [2018-10-06 11:47 UTC] cmb@php.net
-Status: Verified +Status: Closed
 [2018-10-06 11:47 UTC] cmb@php.net
Since <https://github.com/php/php-src/pull/3548> has been merged,
getColumnMeta() table name will be available also for system
libsqlite as of PHP 7.4.0.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Oct 17 11:01:25 2018 UTC