php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41377 upgrade from 5.2.1 to 5.2.2 fails to configure properly
Submitted: 2007-05-12 17:52 UTC Modified: 2008-08-22 18:10 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: rickywalt1 at msn dot com Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.2 OS: windows 2000 server
Private report: No CVE-ID: None
 [2007-05-12 17:52 UTC] rickywalt1 at msn dot com
Description:
------------
I installed 5.2.1 about two months ago.  Everything was working well.

I downloaded and installed 5.2.2, using the windows installer, and now the web server (iis5) returns the error 'The specified module could not be found.' on a simple page that worked in 5.2.1.  It only has as echo() in it.  So it seems to know that .php requires something but can't find the something.

I also removed php completely (deleted the directory too), redownloaded and reinstalled 5.2.2, and still get the same error.  Somewhere, somehow the installer is not doing something correctly.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-05-12 18:41 UTC] rickywalt1 at msn dot com
I also tried the suggestions from the 'manual install' section of the install.txt. (adding isapi filter, adding app mapping, setting script access)

None of this helped either.

btw the application mapping was wrong. see bug 41367.
 [2007-05-12 21:24 UTC] rickywalt1 at msn dot com
firefox gives the 'The specified module could not be found.' error

IE just gives an http 500 error.

hmmmmm
 [2007-05-13 13:04 UTC] zhaoliang_97 at hotmail dot com
Yes, You are right.

I'm the #41367's reporter.

I have spent a whole afternoon to test PHP5.2.2 installer under windows 2000 server sp4(iis5 + isapi).

Now my total test result of PHP5.2.2 installer is:

windows server 2003 + iis6 + isapi : Need to change the wrong application mapping to work(don't forget to restart iis to load php.ini).

windows 2000 server sp4 + iis5 + isapi : although the application mapping still wrong but change it is no use to make php work.

Windows server 2003 users see bug #41367.
 [2007-05-13 16:33 UTC] rickywalt1 at msn dot com
Ok ... so the windows installer bites.

I got 5.2.2 installed by ignoring the windows installer and doing the manual install from the .zip file.

I think the problem may be that the installer doesn't set the permissions on d:\program files\php or the php.ini correctly.  It definitely hoses the path in the application mapping.

Not sure.  don't care any more.
 [2007-05-14 10:12 UTC] zhaoliang_97 at hotmail dot com
Under windows 2000 the everyone has the all controll to the files so permission is not matter.
 [2007-05-16 15:55 UTC] jmertic@php.net
Try latest installer from snaps to see if it does the correct behavior.

http://snaps.php.net/win32/php5.2-win32-installer-latest.msi
 [2007-05-16 16:25 UTC] zhaoliang_97 at hotmail dot com
See my latest test information about the latest installer. bug #41367
 [2007-05-16 17:39 UTC] jmertic@php.net
I'm going to get the installer re-spun for 5.2.2 to correct this.
 [2007-05-16 18:15 UTC] jmertic@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 [2007-05-21 18:30 UTC] jmertic@php.net
Try the following "unoffical" re-spin:

http://files.edin.dk/php/installer/php-5.2.2-2-win32-installer.msi
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 05:03:12 2021 UTC