php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41359 wddx_deserialize does not deserialize char codes >= 192
Submitted: 2007-05-10 18:52 UTC Modified: 2007-05-10 20:26 UTC
From: tim at whiteinteractive dot com Assigned:
Status: Not a bug Package: WDDX related
PHP Version: 4.4.7 OS: Mac OS X 10.4
Private report: No CVE-ID: None
 [2007-05-10 18:52 UTC] tim at whiteinteractive dot com
Description:
------------
wddx_deserialize does not deserialize characters above and including decimal 192 correctly. As follows:

\xC0 -> \x00 
\xC1 -> \x40 
\xC2 -> \x80 
\xC3 -> \xC0 
\xC4 -> \x3F 
\xC5 -> \x3F 
.......... 
\xFF -> \x3F 


I have reported this before and it is still not fixed.


Reproduce code:
---------------
$x = "<wddxPacket version='1.0'><header/><data><string><char code='FF'/></string></data></wddxPacket>";
$s = wddx_deserialize( $x );
var_dump( ord($s) );


Expected result:
----------------
(int)255

Actual result:
--------------
(int)64

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-05-10 20:26 UTC] tony2001@php.net
Duplicate of #40080.

>I have reported this before and it is still not fixed.
There is no maintainer for wddx and he/she won't magically appear if you report your problem twice.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Nov 28 14:01:23 2020 UTC