php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41348 Compilation failure with oci8 support
Submitted: 2007-05-10 11:23 UTC Modified: 2007-05-10 20:05 UTC
From: clement dot demonchy at bsocom dot com Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 5.2.2 OS: Debian Linux Sarge
Private report: No CVE-ID:
 [2007-05-10 11:23 UTC] clement dot demonchy at bsocom dot com
Description:
------------
Hello,

I get a compilation failure when I try to compile php with oci8 support.

The configuration line : 
./configure  --with-apache=../apache_1.3.37 --with-mysql=/usr/local/mysql --enable-track-vars --enable-inline-optimization --enable-memory-limit --enable-ftp --with-zlib-dir=/usr --with-zlib --with-gd --with-png-dir=/usr --with-jpeg-dir=/usr --with-xml --with-gettext --disable-ipv6 --with-ttf --with-freetype-dir=/usr --with-xml2 --with-libxml2 --with-dom --with-dom-xslt --with-pspell --with-openssl --with-oci8=/home/oracle/product/8.1.7 --with-oracle=/home/oracle/product/8.1.7 --enable-sigchild --with-oci8-instant-client --with-curl

The error message during make : 

/bin/sh /usr/src/php-5.2.2/libtool --silent --preserve-dup-deps --mode=compile gcc  -Iext/oci8/ -I/usr/src/php-5.2.2/ext/oci8/ -DPHP_ATOM_INC -I/usr/src/php-5.2.2/include -I/usr/src/php-5.2.2/main -I/usr/src/php-5.2.2 -I/usr/include/libxml2 -I/usr/src/php-5.2.2/ext/date/lib -I/usr/include/freetype2 -I/usr/local/mysql/include -I/home/oracle/product/8.1.7/rdbms/public -I/home/oracle/product/8.1.7/rdbms/demo -I/usr/include/pspell -I/usr/src/php-5.2.2/TSRM -I/usr/src/php-5.2.2/Zend    -I/usr/include -O3  -c /usr/src/php-5.2.2/ext/oci8/oci8_lob.c -o ext/oci8/oci8_lob.lo
/usr/src/php-5.2.2/ext/oci8/oci8_lob.c: In function `php_oci_lob_read':
/usr/src/php-5.2.2/ext/oci8/oci8_lob.c:304: error: `OCI_NLS_CHARSET_MAXBYTESZ' undeclared (first use in this function)
/usr/src/php-5.2.2/ext/oci8/oci8_lob.c:304: error: (Each undeclared identifier is reported only once
/usr/src/php-5.2.2/ext/oci8/oci8_lob.c:304: error: for each function it appears in.)
make: *** [ext/oci8/oci8_lob.lo] Error 1

I'm currently using oracle version 8.1.7.

Best regards.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-05-10 20:05 UTC] tony2001@php.net
Upgrade to newer Oracle version.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 06:02:13 2014 UTC