php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41345 ibase_blob_get bug
Submitted: 2007-05-10 07:30 UTC Modified: 2007-09-07 08:34 UTC
From: peaktop at inbox dot ru Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 5.2.2 OS: WinServer 2003 SP1
Private report: No CVE-ID: None
 [2007-05-10 07:30 UTC] peaktop at inbox dot ru
Description:
------------
I have problem with Firebird API function ibase_blob_get when trying to megre from PHP5.2.1 into PHP5.2.2. 
What I did do:
1) Download PHP5.2.2
2) Stopping Apache.
3) Rename folder with PHP5.2.1-engine
4) Place PHP5.2.2-engine into folder, where was PHP5.2.1-engine.
5) Copy "php.ini" from PHP5.2.1 engine to PHP5.2.2
6) Start Apache
The block of code (listed bellow) is not working.

Reproduce code:
---------------
$db = ibase_connect('127.0.0.1:DB', 'SYSDBA', 'masterkey');
if($db != 0){
  $sql = 'SELECT FIRST 1 * FROM TABL$W_MENU_LEFT M WHERE (M.ID = 10000)';
  $qr = ibase_query($db, $sql);
  if($qr != 0){
    $row = ibase_fetch_object($qr);
    $blob_inf    = ibase_blob_info($row->BODY);
    $blob_handle = ibase_blob_open($row->BODY);
    $out_str.= ibase_blob_get($blob_handle, $blob_inf[0]);
    ibase_blob_close($blob_handle);
    ibase_free_result($qr);
  }
  ibase_close($db);
}


Expected result:
----------------
In PHP5.2.1-engine I had text in browser, which is stored in Firebird database.

Actual result:
--------------
Invalid Blob-handle

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-05-10 20:04 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Dec 14 18:01:24 2019 UTC