php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41314 MSI installer problem/error
Submitted: 2007-05-07 15:34 UTC Modified: 2008-08-22 18:10 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: bluevd at gmail dot com Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.2 OS: Win XP sp2
Private report: No CVE-ID: None
 [2007-05-07 15:34 UTC] bluevd at gmail dot com
Description:
------------
Running php-5.2.2-win32-installer.msi for the instalation
When it reaches the "Copying new files" stage it give error:
Could not read "C:\Windows\Installer\php-5.2.1-win32-installer.msi"

Reproduce code:
---------------
Just download php-5.2.2-win32-installer.msi and run it and continue with the setup as normal.

Expected result:
----------------
When it reaches the "Copying new files" stage it give error:
Could not read "C:\Windows\Installer\php-5.2.1-win32-installer.msi"

Actual result:
--------------
When it reaches the "Copying new files" stage it give error:
Could not read "C:\Windows\Installer\php-5.2.1-win32-installer.msi"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-05-07 15:48 UTC] bluevd at gmail dot com
The workaround is to rename the file from C:\Windows\Installer\php-5.2.2-win32-installer.msi to C:\Windows\Installer\php-5.2.1-win32-installer.msi
This or fixing the MSI scripts.
 [2007-05-07 15:51 UTC] jmertic@php.net
Please try the latest installer version

http://us2.php.net/get/php-5.2.2-win32-installer.msi/from/www.php.net/mirror
 [2007-05-07 15:57 UTC] jmertic@php.net
Also, you may want to try uninstalling PHP 5.2.1 first, then installing PHP 5.2.2. There was a problem with the initial installer released for that version with upgrading, which could be causing the problem.
 [2007-05-14 11:28 UTC] jmertic@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2007-05-29 07:56 UTC] rufusg2 at gmail dot com
XPSP1 - same issue.
Tried renaming file, tried moving to /installer directory (no similar file found there before copying), various combinations of installation settings/choices.
 [2007-05-29 08:21 UTC] bluevd at gmail dot com
The problem is caused by earlier installs and by a certain mixup with the MSI packages. Either try to update the MSI system or try to clean up all previous installs.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 05:03:12 2021 UTC