php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41301 Error in my_thread_global_end():
Submitted: 2007-05-06 07:55 UTC Modified: 2007-05-14 03:28 UTC
From: glen at aquarius dot com dot au Assigned:
Status: Not a bug Package: *Database Functions
PHP Version: 5.2.2 OS: win200 server
Private report: No CVE-ID: None
 [2007-05-06 07:55 UTC] glen at aquarius dot com dot au
Description:
------------
I am installing phpBB3.0B5 and have tried using MySQL as well as MSSQL as their database servers.

When using MySQL as the database, phpBB will not allow user access in IE but will when using Firefox. IE and Firefox work fine when using MSSql as the database.

In either database scenario the following error appears at the foot of each phpBB page:

Error in my_thread_global_end(): 5 threads didn't exit 

phpBB support do not think it's a bug in their software.




Reproduce code:
---------------
http://forums.aquarius.com.au will display the error message.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-05-06 10:34 UTC] tony2001@php.net
>Error in my_thread_global_end(): 5 threads didn't exit 
There is no such function nor error message in PHP.
 [2007-05-06 12:44 UTC] glen at aquarius dot com dot au
Thanks for that - much appreciated.
 [2007-05-06 22:54 UTC] glen at aquarius dot com dot au
The problem is caused by MySQL and has been confirmed (Bug# 25621). It will apparently be fixed in the next release.

In the meantime, if you are using PHP and do not use MySQL then you can disable MySQL by commenting out the reference at the end of php.ini eg:

[PHP_MYSQL]
;extension=php_mysql.dll
 [2007-05-09 15:55 UTC] glen at aquarius dot com dot au
This is becoming a big issue over at MySQL Headquarters :-) Quite a number of programs utilising PHP and NOT commenting out the MySQL library are falling over. NOTE: You don't actually have to use MySQL - just having it enabled in PHP causes the problem as well.

The latest:

[9 May 17:43] Sergei Golubchik

Strictly speaking, this is not MySQL bug. This is a client bug - a
client application (PHP, probably) linked with libmysqlclient calls
my_thread_init() but does not call my_thread_end() as appropriate
(doesn't call at all or calls too late). MySQL client library detects
this and issues a warning.

On the other hand, we can just remove the check and let buggy
applications to fail some other way. Not calling my_thread_end() is a
guaranteed memory leak. Calling it too late could easily crash the
application.
 [2007-05-09 16:32 UTC] derick@php.net
We don't call my_thread_init, or anything starting with my_thread:

derick@kossu:~/dev/php/php-5.2dev$ grep -r my_thread *
derick@kossu:~/dev/php/php-5.2dev$ 

 [2007-05-14 03:28 UTC] glen at aquarius dot com dot au
The following comments have been made in the MySQL Bug reports for this bug:

[14 May 3:34] Siew Pui Tong

I have upgraded to PHP 5.2.2.
I cfm that using libmysql.dll from 5.2.1, instead of 5.2.2 solved the
pbm.

------------------------------------------------------------------

[13 May 23:20] Nathan (York Networks)

I started seeing this bug after upgrading from PHP 5.1.x to 5.2.2.
Interestingly, copying the libmysql.dll from the 5.1.x version in to
the 5.2.2 release appears to have resolved the issue at list until the underlying problem is addressed.

---------------------------------------------------------------------

I have also changed the file and both phpBB3 and WordPress are now seemingly working fine.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 04 16:01:27 2020 UTC