php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41265 spurious error about missing iconv
Submitted: 2007-05-03 02:19 UTC Modified: 2007-05-04 21:57 UTC
From: paul at ensigma dot com dot au Assigned:
Status: Closed Package: GD related
PHP Version: 5.2.1 OS: Linux - Slackware 11.0
Private report: No CVE-ID:
 [2007-05-03 02:19 UTC] paul at ensigma dot com dot au
Description:
------------
./configure reports missing iconv when in fact ttf is missing

Configuration line was:

./configure --with-mysql --with-gd --with-ttf --enable-track-vars  --with-apxs2=/usr/local/apache2/bin/apxs --with-jpeg  --with-png --with-zlib --with-tiff --with-gdbm --with-pdflib=/usr/local --with-freetype  --enable-mbstring

failed to compile complaining about iconv install but iconv is correctly installed.

Reproduce code:
---------------
Run above configuration line with no libttf

Expected result:
----------------
Successful compile

Actual result:
--------------
checking for iconv support... yes
checking for iconv... no
checking for libiconv... no
checking for libiconv in -liconv... no
checking for iconv in -liconv... no
configure: error: Please reinstall the iconv library.


Config.log shows the issue:

int main() {
libiconv()
; return 0; }
configure:44525: checking for iconv in -liconv
configure:44544: gcc -o conftest -g -O2  -Wl,-rpath,/usr/local/lib -L/usr/local/lib  conftest.c -liconv  -lttf -lpng -lz -lgdbm -lz -lresolv -lm -ldl -lnsl  -lxml2 -lz -lm -lxml2 -lz -lm 1>&5
/usr/lib/gcc/i486-slackware-linux/3.4.6/../../../../i486-slackware-linux/bin/ld: cannot find -lttf
collect2: ld returned 1 exit status
configure: failed program was:
#line 44533 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char iconv();

int main() {
iconv()
; return 0; }

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-05-03 10:29 UTC] tony2001@php.net
The config.log clearly says what is the problem.
 [2007-05-03 23:49 UTC] paul at ensigma dot com dot au
The error from ./configure is still very misleading. Do you expect that people to ignore a specific error report like that and then go hunting to find out what the real problem is? It certainly wasn't my first thought - I figured there was something wrong with iconv. If hunting down to config.log is the MO then maybe the error should say "Something has gone wrong check config.log to find out what"
 [2007-05-04 21:16 UTC] sniper@php.net
Obviously the freetype checks are not done properly.
 [2007-05-04 21:57 UTC] sniper@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 16 22:02:05 2014 UTC