php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41238 PSpell fails to open dictionaries when server is under load
Submitted: 2007-04-30 09:45 UTC Modified: 2007-04-30 13:10 UTC
From: spam02 at pornel dot net Assigned:
Status: Not a bug Package: Pspell related
PHP Version: 5.2.1 OS: Debian stable
Private report: No CVE-ID: None
 [2007-04-30 09:45 UTC] spam02 at pornel dot net
Description:
------------
Problem reported in #33095 might be valid.

I can reproduce the same problem, every time, on PHP/5.2.1, Linux/2.6.8, Apache/1.3.33, Aspell/0.60.3

It appears that PHP process which uses PSpell must be the only process on the server (even images loading concurently affect it.), otherwise PSpell fails to open dictionary.

Failure seems to be determined per process, because PSpell will either work first time or always fail for a certain process (when you retry in a loop, even with a delay, you always get failure).

I've tried different invocation methods, pspell_clear_session, clearstatcache, different dictionaries - nothing helps.


Reproduce code:
---------------
Try pspell on pages with and without images. 

Different browsers have different patterns for requesting images, so for example failure rate is higher in Firefox than Opera (I'm not mad, really).



Actual result:
--------------
Warning: pspell_new_config() [function.pspell-new-config]: PSPELL couldn't open the dictionary. reason: No word lists can be found for the language "en". in ...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-04-30 13:10 UTC] tony2001@php.net
Pspell library problems should be reported to Pspell developers.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Jul 20 20:01:26 2019 UTC